Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install git using my yum command

Following is the error log

Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package git.x86_64 0:1.8.2.1-1.el5 will be installed
--> Processing Dependency: perl-Git = 1.8.2.1-1.el5 for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: perl(Term::ReadKey) for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: perl(Git) for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: perl(Error) for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: libssl.so.6()(64bit) for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: libexpat.so.0()(64bit) for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: libcurl.so.3()(64bit) for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package: git-1.8.2.1-1.el5.x86_64
--> Running transaction check
---> Package git.x86_64 0:1.8.2.1-1.el5 will be installed
--> Processing Dependency: libssl.so.6()(64bit) for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: libexpat.so.0()(64bit) for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: libcurl.so.3()(64bit) for package: git-1.8.2.1-1.el5.x86_64
--> Processing Dependency: libcrypto.so.6()(64bit) for package: git-1.8.2.1-1.el5.x86_64
---> Package perl-Error.noarch 1:0.17010-1.el5 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: 1:perl-Error-0.17010-1.el5.noarch
---> Package perl-Git.x86_64 0:1.8.2.1-1.el5 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-Git-1.8.2.1-1.el5.x86_64
---> Package perl-TermReadKey.x86_64 0:2.30-4.el5 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.8.8) for package: perl-TermReadKey-2.30-4.el5.x86_64
--> Finished Dependency Resolution
Error: Package: git-1.8.2.1-1.el5.x86_64 (epel)
           Requires: libssl.so.6()(64bit)
Error: Package: git-1.8.2.1-1.el5.x86_64 (epel)
           Requires: libexpat.so.0()(64bit)
Error: Package: perl-Git-1.8.2.1-1.el5.x86_64 (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: git-1.8.2.1-1.el5.x86_64 (epel)
           Requires: libcrypto.so.6()(64bit)
Error: Package: perl-TermReadKey-2.30-4.el5.x86_64 (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: 1:perl-Error-0.17010-1.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: git-1.8.2.1-1.el5.x86_64 (epel)
           Requires: libcurl.so.3()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The command yum repolist

Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
repo id                                                                     repo name                                                                                                          status
epel                                                                        Extra Packages for Enterprise Linux 5 - x86_64                                                                      7,351
rpmforge                                                                    RHEL 6Server - RPMforge.net - dag                                                                                  11,275
repolist: 18,626

Please help me install and resolve these missing dependencies

uname --kernel-release
2.6.32-279.el6.x86_64
share|improve this question
    
Please share the actual yum command you're using in the above scenario. –  slm Jun 25 '13 at 18:51

2 Answers 2

up vote 3 down vote accepted

Try disabling the RPMForge repo

Do the command as follows:

$ sudo yum --disablerepo=rpmforge install git

The repositories EPEL and RPMForge don't get along that well.

Mixing EPEL6 repos with EPEL5?

If the above doesn't resolve the issue then it would appear that you're mixing EPEL6 repositories with your CentOS 5 installation. In looking at a CentOS 5 installation I have here I have the following repositories:

$ yum repolist
Loaded plugins: fastestmirror
repo id                                  repo name                                                                            status
base                                     CentOS-5 - Base                                                                       3,641
convirt                                  ConVirt repository                                                                        4
convirt-dep                              ConVirt Dependencies                                                                      7
elrepo                                   ELRepo.org Community Enterprise Linux Repository - el5                                  412
extras                                   CentOS-5 - Extras                                                                       270
rpmforge                                 RHEL 5 - RPMforge.net - dag                                                          11,275
updates                                  CentOS-5 - Updates                                                                      447
repolist: 16,056

See what versions of git I have outside of RPMForge:

$ sudo yum --disablerepo=rpmforge list all git*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nexcess.net
 * elrepo: elrepo.org
 * extras: centos.mirrors.tds.net
 * updates: mirrors.einstein.yu.edu
Installed Packages
git.x86_64                                                1.7.10.4-1.el5.rf                                                installed

The above shows that if I disable RPMForge, the only version of git available for my mix of repos is the one coming from RPMForge, and the latest version is 1.7.

Given this It would appear that you're mixing a package from CentOS 6, would be my guess.

References

share|improve this answer
    
After running the above command I still get the same error –  Anand Sunderraman Jun 25 '13 at 18:08
    
@AnandSunderraman - Sorry I gave you the wrong command, please try the updated answer now. Sorry about that. –  slm Jun 25 '13 at 18:11
    
thanks but the updated command also returns the same error. –  Anand Sunderraman Jun 25 '13 at 18:12
    
Where are the rest of your repo's in that yum repolist command? I get these: base, epel, extras, updates, rpmforge on CentOS 5. –  slm Jun 25 '13 at 18:21
1  
@AnandSunderraman - Can you look in your /etc/yum.repo.d/* files and make sure you're not pointing to EL6 repos? I don't see 1.8 available in the epel for EL5. I think you're mixing repos. –  slm Jun 25 '13 at 18:30

The problem on the CentOS 6 server I was working on was that EPEL 5 was installed I found this through the following command.

sudo yum repolist

I solved this through the following commands:

wget http://mirror.umd.edu/fedora/epel/6/i386/epel-release-6-8.noarch.rpm
sudo yum remove epel-release
sudo rpm -ivh epel-release-6-8.noarch.rpm --test
sudo rpm -ivh epel-release-6-8.noarch.rpm
sudo yum update
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.