Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Having obtained the kfreebsd ISO image from here, I set up a VirtualBox VM to install from the ISO.

When I boot up the VM, the session ends up with the grub menu instead of initializing the installation process or starting a shell.

  1. How can I proceed from the GRUB menu to boot up kfreebsd for installation?
  2. What could be causing the boot disc to enter grub instead of loading kfreebsd?
share|improve this question

I would make sure that you have the CDROM device checked so that it's bootable. You can do this under the preferences for the VM in Virtualbox.

For example:

   ss of VB prefs

Additionally you want to make sure that the ISO has been property mounted as a CDROM under Storage section of the VM's preferences:

   ss of ISO

In some rare cases I've unchecked every drive from being mountable to get the CDROM ISO to boot inside the VM and then later after the installation has completed, come back and re-check the main HDD.

share|improve this answer
Thanks @@slm, turned out the problem is caused by running the ISO file via a virtual CD/DVD Drive application (Virtual Clone Drive) in Windows. When I create an IDE device directly in VirtualBox using the ISO file, kFreeBSD boots successfully. – hanxue Jun 25 '13 at 17:17
@hanxue - glad your issue was resolved. Can you either mark this answer as the accepted one or write up your resolution so that other's know that your question has been resolved. – slm Jun 25 '13 at 17:22
Sure, was writing up the answer as you comment :) Thanks again for the quick help – hanxue Jun 25 '13 at 17:45
@hanxue - yup NP. Good write up. What did you use to circle the text in your screenshots? – slm Jun 25 '13 at 17:48
I used paint.NET to crop and add in the rounded rectangles. Most drawing applications should have a rounded rectangle shape. I have not used *nix GUI apps for a bit, and a quick search shows how to do it on Inkscape inkscape.org/doc/shapes/tutorial-shapes.html Hope that helps. – hanxue Jun 25 '13 at 18:11

The error turned out to be a combination of loading the ISO file through a Windows CD/DVD emulator and not enabling passthrough when selecting the emulated drive.

How to reproduce the problem

  1. Select the emulated drive where the kFreeBSD ISO image is mounted on (F:\ in this example)

Select emulated ISO drive

  1. Ensure the ISO has been mounted by the CD/DVD emulated, in this case Virtual CloneDrive

Mount ISO image

  1. Start the VM. You will see the grub menu instead of kFreeBSD booting up

kFreeBSD ends up in grub


  1. Enable passthrough for the virtual drive, or

passthrough for emulated ISO

  1. Directly select the ISO image file from VirtualBox
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.