Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Fedora 18. I'm trying to configure my synaptics touchpad, I need the tapping and the horizontal scrolling inside Awesome Window Manager.

I've created a file at /etc/X11/xorg.conf.d/50-synaptics.conf with the following contents:

Section "InputDevice"
        Identifier "touchpad"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "HorizEdgeScroll" "on"
EndSection

But when I start the system, it hangs at different points, one that I saw frequently is :

Failed to start Wait for Plymouth Boot Screen to Quit.
See 'systemctl status plymouth-quit-wait.service' for details.

If you want a log file or something just tell me how to get it.

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

Change the first line in 50-synaptics.conf to

Section "InputClass"

InputDevice was used to define rules and options for a specific device and I'm not sure if it's still supported.

InputClass is a newer section that allows for matching a number of connected devices depending on various match rules. Because you have the line MatchIsTouchpad you should be using InputClass. This way you're telling xorg to match these rules to all touchpads. You can see the Fedora documentation for more details.

share|improve this answer
    
Worked like a charm. Could you tell me what's the difference between InputClass and InputDevice. Also horizontal edge scroll is still not working, is there something wrong with what i've typed above ? –  Rafael Adel Jun 25 '13 at 12:39
1  
It might be that touchpad settings for synaptics devices do not work from xorg.conf files. Does typing synclient HorizEdgeScroll=1 in a terminal enable horizontal scrolling? –  drs Jun 25 '13 at 12:51
1  
Alternatively, try adding Option "SHMConfig" "true" to the config file inside the InputClass section. –  drs Jun 25 '13 at 13:03
    
I've figured it out, thanks a lot for your help. –  Rafael Adel Jun 25 '13 at 13:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.