Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How can I persistently prevent a wireless interface using wpa_supplicant in roaming mode from connecting to a particular open network foo?

This doesn't work:

$ sudo wpa_cli
> blacklist 00:11:22:33:44:55
FAIL

Nor does the following:

/etc/network/interfaces:

allow-hotplug wlan0
iface wlan0 inet manual
  wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

wpa_supplicant.conf:

network={
 ssid="foo"
 key_mgmt=NONE
 priority=0
}
share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You can set the option disabled=1 in the corresponding network entry in wpa_supplicant.conf. This will prevent wpa_supplicant to automatically connect to the network (it'll still try to connect to it if you specifically ask it to do so).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.