Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After 5 unsuccessful Arch Linux installations, I've got two that installed correctly. The first time, the network worked fine, and I was even installing it over SSH.

After booting from the installed system instead of the live CD, it can't connect to the network, I get the following message when I try to ping anything, even my router:

connect: Network is unreachable

I've tried installing Arch again, because nothing on the internet seemed to fix my issue. After installing, I'm getting the same issue.

It appears it's failing to start eth0 because it times out.

share|improve this question
    
Did you try dhcpcd eth0 ? –  uzsolt Jun 24 '13 at 14:49
    
@uzsolt Yes, it gives a Failed to issue method call: No such file or directory error. I've also posted a topic over at the official forums, I will be posting the answer here if I find one. –  Novicode Jun 24 '13 at 14:56
    
ifconfig eth0 up already done? Does linux see your network card (module are loaded)? Before anything please systemctl stop netctl-eth0... –  uzsolt Jun 24 '13 at 14:57
    
Damn... you've no eth0, you've... I can't read it :( bbs.archlinux.org/viewtopic.php?pid=1291880#p1291880 So you should set up NO eth0, you should use instead enp1s0 (or what the hell is on your photo :) ). –  uzsolt Jun 24 '13 at 15:02
    
I'm glad solved your problem. –  uzsolt Jun 24 '13 at 17:27

2 Answers 2

Network unreachable means you don't have a route to the network. If you can't even ping the local router, either you don't have an IP address or your network interface is down.

netctl is the standard utility for managing network interfaces in Arch. If you haven't set that (or something else) up, you won't have any network. Not even DHCP.

share|improve this answer
    
I have copied an example file from examples/ethernet-static to "my-network", modified that file, then enabled it on startup with "netctl enable my-network". There are no IP conflicts on the network, either. It should be "Set up" –  Novicode Jun 24 '13 at 13:40
up vote 1 down vote accepted

The problem I was facing was that there was no eth0 (from what I can understand.) Run the command ip link, this should output your interfaces. I did not have the eth0 interface. Instead I had enp1s8.

Because I was using static, I copied the example profile with cd /etc/netctl then cp examples/ethernet-static my-network. After that, I edited my-network with nano my-network, and changed the Interface from eth0 to en1s8 (or whatever your adapter is in ip link). Finally, I enabled it to use that profile on startup with netctl enable my-network. You may need to restart. I was able to get help on the official Arch Linux forums, you can view my topic there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.