Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running on CentOS 5.7 (in case that matters) I have a program (not my own) that runs fine from Lonsole, but when I run it from xterm, gnome-terminal or rxvt, it just hangs.

I'm doing this with a completely fresh account, no .bashrc, no alterations to defaults. Brand new vanilla install.

On both terminals, $- is himBH so, both the same type of shell, I would think.

If I ssh into the machine, even from itself (ssh 127.0.0.1), it works in all terminals.

Any idea what could be wrong?

EDIT: The program is qconf, part of SGE (GridEngine), in case that matters. It goes to a server and returns a list of machines that are allowed to make compute requests.

I ran with traces, the diff looks like:

diff broken working
1,4c1,4
< execve("/opt/SGE/bin/lx24-amd64/qconf", ["qconf", "-ss"], [/* 49 vars */]) = 0
< brk(0)                                  = 0x1a48c000
< mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2ba0bec8a000
< mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2ba0bec8b000
---
> execve("/opt/SGE/bin/lx24-amd64/qconf", ["qconf", "-ss"], [/* 48 vars */]) = 0
> brk(0)                                  = 0xa7cb000
> mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =     0x2b3b4716e000
> mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x2b3b4716f000
6,19d5

.
.
.
< futex(0x3a408030ec, FUTEX_WAKE_PRIVATE, 2147483647) = 0
< futex(0x6ba3c0, FUTEX_WAIT_PRIVATE, 2, NULL
\ No newline at end of file
---
> open("/proc/cpuinfo", O_RDONLY)         = 3
> read(3, "p", 1)                         = 1
> read(3, "r", 1)                         = 1

[working goes on from here]

Broken stops in mid futex output, which is odd.

share|improve this question
    
What does the program do? Can we see it? –  terdon Jun 21 '13 at 15:40
    
Do you run the program directly inside a terminal, or from a shell? What is the program doing? At least post a trace: xterm -e strace -o your_program.xterm.strace ./your_program. Compare with the trace in Konsole. –  Gilles Jun 21 '13 at 15:44
    
What version of GridEngine (SGE) is this? –  slm Jun 24 '13 at 16:53
    
At the bottom of the man page it says 6.2u5 –  Brian Postow Jun 24 '13 at 17:56
    
One possibly interesting thing is that the final call to futex appears to have an extremely small 3rd arg, and an unnecessary 4th arg... –  Brian Postow Jun 24 '13 at 18:02
show 1 more comment

1 Answer

I have the same configuration i.e.: Centos 5.7 and SGE 6.2u5. No problems. I can work directly on server console, or x-term. I can ssh both in text- and x-modi. Everything works.

The only thing that comes to my mind is initialisation of SGE-environment. Are you sure it's done properly? I had some users that "somehow" managed to make it wrong. For that reason I added SGE-initialization to /etc/profile. Smth like this:

   if [ -f /Services/NFS/SGE/default/common/settings.sh ];then
     . /Services/NFS/SGE/default/common/settings.sh
   fi

Did you compiled SGE your-self or did you use Sun's binaries for 64-bit linux (ge-6.2u5-bin-lx24-amd64.tar.gz ge-6.2u5-common.tar.gz)?

share|improve this answer
    
I'm not admin on the system, so I didn't compile anything. I'm accessing the system via a virtual computer system called No-Window, or NX. It's possible that NX isn't set up correctly, and so it breaks things... But how would that affect SGE? –  Brian Postow Jun 26 '13 at 20:01
    
There could be a lot of reasons. Missing/incompatible libraries, wrong export of system variables for the start. But you can check it easily enough. NX is a remote desktop. SO I assume you work with this on windows or mac machine. Try to use x-server instead and see if this works. If you work on windows try the demo version of Xwin32 from Starnet. It works for 30min then it closes the session. Of course in text modus you can use putty from Simon Tatham. –  Kris_R Jun 27 '13 at 9:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.