Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install sshfs on Linux Mint to mount remote folders over SSH. I've Googled up and down on how to install sshfs (as the command is not available to me) and I'm beating my head against the wall because I cannot find the repository it is in.

~ $ sshfs
The program 'sshfs' is currently not installed. You can install it by typing:
sudo apt-get install sshfs
~ $ sudo apt-get install sshfs
[sudo] password for XXXX: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package sshfs

Edit: Adding response to @Nate from Kalamazoo's answer here for code formatting:

~ $ sudo apt-get install sshfs-fuse
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package sshfs-fuse
~ $ apt-cache search sshfs
~ $ 

Edit: Adding output of cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list:

deb http://packages.linuxmint.com/ olivia main upstream import
deb http://ppa.launchpad.net/dockbar-main/ppa/ubuntu raring main
deb-src http://ppa.launchpad.net/dockbar-main/ppa/ubuntu raring main
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main
#deb file:///usr/share/local-repository binary/

deb http://ppa.launchpad.net/nuvola-player-builders/stable/ubuntu raring main
deb-src http://ppa.launchpad.net/nuvola-player-builders/stable/ubuntu raring main
# Do not edit this file manually, use Software Sources instead.

deb http://packages.linuxmint.com olivia main upstream import  #id:linuxmint_main

deb http://archive.ubuntu.com/ubuntu raring main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu raring-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ raring-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ raring partner
deb http://ppa.launchpad.net/webupd8team/jupiter/ubuntu raring main
deb-src http://ppa.launchpad.net/webupd8team/jupiter/ubuntu raring main
deb http://ppa.launchpad.net/webupd8team/sublime-text-2/ubuntu raring main
deb-src http://ppa.launchpad.net/webupd8team/sublime-text-2/ubuntu raring main

All tutorials I find don't mention adding any repositories, just to do the usual install. I'm at a loss. Can someone help me out on this relatively simple issue?

share|improve this question
    
I thought Mint included Ubuntu's package sources, and sshfs is definitely in Ubuntu. Please post the output of cat /etc/apt/sources.list /etc/apt/sources.list.d/*.list. What version of Mint is this? –  Gilles Jun 20 '13 at 23:01
    
@Gilles Added to post. Mint 15. –  Michael Irigoyen Jun 21 '13 at 13:06
add comment

4 Answers

up vote 2 down vote accepted

Mint (assuming you are using Mint and not Mint Debian) can use Ubuntu repositories. They should in fact be configured by default but they don't seem to be in your sources.list. Add this line to your sources:

deb http://packages.ubuntu-com raring main restricted

Then run

$ sudo apt-get update
$ sudo apt-get install sshfs

If that doesn't work, download the package from here and install using

$ sudo dpkg -i sshfs_2.4-1ubuntu1_amd64.deb
share|improve this answer
    
Downloading in manually and installing via dpkg worked. –  Michael Irigoyen Jun 21 '13 at 13:53
add comment

How about sudo apt-get install sshfs-fuse ?

Failing that, what does apt-cache search sshfs return?

share|improve this answer
    
No dice. I updated my question (for formatting issues) to show you what I get. –  Michael Irigoyen Jun 20 '13 at 19:23
    
Nuts. Does your sources.list look decent? grep -v '^#' /etc/apt/sources.list –  Nate from Kalamazoo Jun 20 '13 at 19:33
    
# deb http://archive.getdeb.net/ubuntu raring-getdeb apps games. -v returned nothing. That's the contents of the file. –  Michael Irigoyen Jun 20 '13 at 19:38
    
Let's take this to chat chat.stackexchange.com/rooms/26/unix-and-linux –  Nate from Kalamazoo Jun 20 '13 at 19:41
add comment

Please try the following:

$ sudo apt-get update
$ sudo apt-get install sshfs
share|improve this answer
    
I always run an update before trying to install a new package. I'm not new to Linux, but I understand why you may have assumed so as I am a new poster to this site. Alas, this results in the same issue. sshfs is not being found. –  Michael Irigoyen Jun 20 '13 at 19:29
1  
Maybe there is no port for Mint....in which case you'd have to download/make/install it from the source site. –  mdpc Jun 20 '13 at 19:44
    
I suppose that's a possibility. However, Mint uses a lot of Ubuntu sources, so I would assume a Ubuntu port would work on Mint, no? –  Michael Irigoyen Jun 20 '13 at 19:48
1  
I would find the .deb file and just download that and install using dpkg -i <sshfs deb file>. –  slm Jun 20 '13 at 20:24
add comment

I was having similar problems installing Ubuntu packages. In desperation, I opened the "Software Sources" application, changed my Ubuntu mirror (to one much closer), selected application source and backports. After updating, I'm able to install applications from Ubuntu repositories. I tried to retrace the steps I took to see which step had the effect, but even after undoing everything Ubuntu packages still were in the cache. Thus, I'm not sure which step above fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.