Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today I noticed that NetworkManager is not storing passwords for WPA2 networks. I enter the password on connecting, but when I go to the Network Connections dialog the password field is blank and I get on the terminal:

** (nm-connection-editor:23985): WARNING **: Invalid setting Wi-Fi Security: Invalid Wi-Fi security

Even as root this happens. In fact, network information is supposed to be in /etc/NetworkManager/system-connections but this directory is empty.

For now I'm using wicd, even though it doesn't see much updating anymore. Any ideas?

I'm running Fedora 18 and the NetworkManager-related packages I have are:

share|improve this question
Is it an issue with SELinux? forums.fedoraforum.org/showthread.php?t=288322 – slm Jun 20 '13 at 11:40
I disabled SELinux already, didn't help. – Renan Jun 20 '13 at 11:41
Did you look through the open issues? admin.fedoraproject.org/pkgdb/acls/bugs/NetworkManager – slm Jun 20 '13 at 11:43
You might want to try a newer version of NM from here: admin.fedoraproject.org/updates/search/…, as a last ditch effort if you can't resolve it any other way. – slm Jun 20 '13 at 12:07
I will try it when I get home, then I will update the question. – Renan Jun 20 '13 at 15:46
up vote 1 down vote accepted

Well, it seems that reinstalling NetworkManager has worked.

share|improve this answer

Make sure gnome-keyring is installed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.