Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Ubuntu 12.04 Server with Webmin, bind9, and a GUI. It has two ethernet cards: eth0 coming in, and eth1 to talk to clients. My client gets an IP address from DHCP, but cannot connect because "DNS is not responding" (Windows 7), even though it's detected. I was seeing a lease, but changed something and now I don't see a lease in webmin.

Edit 1

netstat output:

Proto  Recv-Q  Send-Q  Local_Addr        Foreign_Addrs  ST      PID
tcp    0       0       127.0.0.1:3306    0.0.0.0:*      LISTEN  220/mysqld
tcp    0       0       10.0.0.254:53     0.0.0.0:*      LISTEN  9782/named
tcp    0       0       192.168.1.216:53  0.0.0.0:*      LISTEN  9782/named
tcp    0       0       127.0.0.1:53      0.0.0.0:*      LISTEN  9782/named
tcp    0       0       0.0.0.0:22        0.0.0.0:*      LISTEN  9724/sshd
tcp    0       0       127.0.0.1:953     0.0.0.0:*      LISTEN  ???
share|improve this question
    
This is a bad question. You don't even tell us whether DHCP still works (for the client). It does not tell us anything about what you have done (or tried). Does that mean you have tried nothing? Do you have SSH access? –  Hauke Laging Jun 18 '13 at 14:06
add comment

1 Answer

You should check whether

  1. DNS is running (ps, netstat --inet -lnp, DNS start script)
  2. DNS queries from the client reach the server (tcpdump -i eth1 -n udp port 53)
  3. the firewall blocks access to DNS (iptables -L INPUT -nv)
  4. the DNS server is configured correctly (host unix.stackexchange.com 127.0.0.1)
share|improve this answer
    
2. tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on eth1, link-type EN10MB (Ethernet), capture size 65535 bytes –  Pearce Jun 18 '13 at 17:14
    
I sorry I did all for steps I have answers but i don't know how to post them correctly to your answer. –  Pearce Jun 18 '13 at 17:27
    
@JuliePearce You should edit your question and add the information there. You should indent output with four spaces " " so that it gets the correct formatting. –  Hauke Laging Jun 18 '13 at 17:39
    
1)Proto Recv-Q Send-Q Local Addr Foreign Addrs ST PID<br/> tcp|0|0|127.0.0.1:3306|0.0.0.0:*|LISTEN|220/mysqld<br/> <br/>tcp|0|0|10.0.0.254:53 |0.0.0.0:*|LISTEN|9782/named <br/> tcp|0|0|192.168.1.216:53|0.0.0.0:*|LISTEN|9782/named <br/> tcp|0|0|127.0.0.1:53|0.0.0.0:*|LISTEN|9782/named <br/> tcp|0 0|0.0.0.0:22|0.0.0.0:*|LISTEN |9724/sshd <br/> tcp|0|0|127.0.0.1:953|0.0.0.0:*|LISTEN| –  Pearce Jun 18 '13 at 19:00
    
3.Chain INPUT (policy ACCEPT 24308 packets, 10M bytes) pkts bytes target prot opt in out source destination –  Pearce Jun 18 '13 at 19:08
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.