Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've got an OpenGL application which I'd like to run over on EC2. I've gotten Mesa 3D working using the libgl1-mesa-swx11, but its a little slow.

So I looked into using LLVMPipe to render and I can't seem to get it to work. I've installed LLVMPipe according to https://launchpad.net/~oibaf/+archive/graphics-drivers on Ubuntu but it still gets the same error of not having a display to render to. I tried installing libgl1-mesa-swx11 and then installing LLVMPipe, but when I do LIBGL_ALWAYS_SOFTWARE=1 glxgears -info I still get

GL_RENDERER = Mesa X11

GL_VERSION = 2.1 Mesa 7.11

GL_VENDOR = Brian Paul

Can anyone help me out with using LLVMPipe on ec2?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.