Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Debian 7 on vmware workstation.
When I run Applications - System Tool - Software Update I just get a blank window, nothing happends. Updating the system works fine with "apt-get update && apt-get -u dist-upgrade".
But when I do this, I get a GUI window with "Could not get update, failed to process request - more details: Operation was cancelled". I'm running gnome as a normal user (not root).
Not able to find anything interesting in /var/log/*

Anyone got any ideas what's causing this?

share|improve this question
add comment

1 Answer

When I was having a similar issue with Debain 7.4 "Wheezy", it seemed to be with the gnupg setup.

When I ran apt-key update for the first time, it failed with errors about no central gpg skeleton, I think was the error (Sorry it escapes me now..)

So, I installed the gnupg2 package:

  1. su -c 'apt-get install gnupg2'

Then to generate all the necessary configuration in your ~/.gnupg directory, I manually started the gpg-agent:

  1. gpg-agent --daemon

I was then able to update the local APT keyring:

  1. su -c 'apt-key update'

Hopefully that will get you on your way, or at least give you a place to start. Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.