Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I used Ubuntu for long even along Windows and SOMETIMES I got this problem for mounting the corresponding NTFS partition at the beginning, however with a pair of command lines to the console I got it fixed.

However, I moved to Linux Mint MATE 15 and I'm ALWAYS getting this problem, I've looked up and I know there's this new use for the hibernation file in Windows 8 which enables fast start up.

Why can't I just mount my NTFS partition ignoring the hibernation file? Is this even possible? And, again, why would this get worse with Linux Mint?

I really like the quicker boot of Windows 8 so I don't really consider disabling Windows hibernation and going to Windows to restart and log to Linux is cumbersome...

share|improve this question
    
When you write to a filesystem, part of the data is kept in RAM, for quick access. It is sent to the disk later. When an OS is hibernated, that data is put in the hibernation data: if you access the filesystem with another OS, you see a state that may not represent what the first OS has virtually done on the disk. It's a bad habit on NTFS and other journaled filesystems, and even more dangerous on FAT and other non-journaled ones. That's why you are not allowed to write - when the first OS resumes, it will expect the original f.s. state and assume the changes buffered in RAM still apply. –  ignis Jun 17 '13 at 16:58
1  
Sure, you could ignore the hibernate state and just mount the disk writeable with force. But ignis is right, it is too dangerous to mount a hibernated disk. But I wonder maybe: isn't the endangered data zero, if you are just in the fast-startup-hibernation state? –  rubo77 Sep 10 '13 at 21:20

6 Answers 6

up vote 3 down vote accepted

You can mount the Windows partition read-only. This will work even if it is hibernated (but of course you cannot update files or write new ones).

The reason you cannot mount the Windows C: drive is that with Fast-start Windows 8 is actually hibernating automatically for you - but only the system session. From a Linux point of view it's the same as if you hibernated yourself.

If you want to mount it read-write you have to Restart from Windows, not Shut down. Shutting down hibernates the system image, but Restarting does not.

share|improve this answer
    
There is also an option to change the shutdown behaviour of windows, so you can shutdown normally without problems. see my answer below –  rubo77 Sep 10 '13 at 19:32

I also would like to know, if it was possible to just delete the hibernate file in Linux.

But just for info, if you want to disable the "Fast Startup" option in windows 8 anyway, I found this:

Unable to mount Windows (NTFS) filesystem due to hibernation

There is a new feature in Windows 8 called Fast Startup. If this feature is enabled (which it is by default), Windows 8 does not actually completely shutdown when you choose shutdown. Instead, it does a "hybrid shutdown". This is something like hibernating; it makes booting Windows 8 back up faster. So, you need to disable this feature to be able to shut it down properly, and be able to mount the Windows partitions. To do this, boot into your Windows 8 and:

Note: disabling Fast Startup will most likely make your Windows 8 take a longer time to boot. There are no "exact" numbers, but let's say that if it took you 10 seconds to boot into Windows 8, it will now take you 50 seconds after disabling this feature.

1. Open Control Panel in the small icons view and click on Power Options.
2. Click on Choose what the power buttons do.
3. Click on Change settings that are currently unavailable.
4. Uncheck Turn on fast startup (recommended).
Click on the numbers above to see screenshots.

Click on Save changes. Now, shutdown Windows 8 and boot back into Linux. You'll be able to mount without getting errors.

Source: Fast Startup - Turn On or Off in Windows 8.

share|improve this answer

Different distributions are free to make deviations from each other.

Thus what might effectively work in one Linux distribution might not work in another. Could be kernel versions, support utilities versions that are supported on each are not identical. It looks like this is what you are running into.

share|improve this answer

None of the older answers seem to work anymore. I don't know if there is a new answer. On my latest purchase of a new Windows 8 machine, I have disabled fast startup, completely removed hibernate mode and used restart to switch to the Linux OS (also Mint 15) and it doesn't matter. Linux sees the NTFS partition one way (for a while) and your changes are there as long as you don't reboot Windows again, but as soon as you reboot Windows, your Linux changes are just gone. Then if you go back to Linux, you may see your changes, if your lucky, but eventually (for me, always by the 2nd reboot) they are gone from both OS views. Windows is viewing its partition its own way (changes must be delayed, somewhere, even without hibernation) and eventually overwrites your Linux work (that it never seems to see). I have only seen large files written from Linux appear occasionally after a Windows chkdsk /f (as recovered data). I don't know if the new "System Protection" for partitions has anything to do with this.

share|improve this answer

I have been dual booting Windows and Linux since 2005. The best way is to never mount the Windows OS partition in Linux. What you need to do is shrink the partition with Windows on it to the size needed, usually 40 - 80 GB for Windows 7. Then create a new partition in the freed up space. Keep all of your data on that partition. You can then access your data partition in Linux and you never need to mount the Windows partition (usually C: drive)

I don't know about Windows 8, however.

share|improve this answer
    
Yeah, that's best alternative solution. It doesn't even only solves the problem but avoids it. –  diegoaguilar Sep 27 '13 at 15:48

In windows 8 create a desktop shortcut to:

%SystemRoot%\System32\shutdown.exe -s -f -t 5 -c "System fully shutting down - Bye-bye!"

And use that to shut down windows. Full system shutdown with no hibernation, you can mount the ntfs partion with no troubles now. Protip: pin a copy of the shortcut to the startbar, add another with shutdown -a if you want an option to abort the shutdown in the 5 second timeout.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.