Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm new to Linux and Heroku. I downloaded the Heroku Toolbelt into my CentOS/VirtualBox setup using the following command:

wget -qO- https://toolbelt.heroku.com/install.sh | sh

However, according to the man pages, wget just downloads files, it does not install (is this correct?). I double checked to see if Heroku Toolbelt was installed with this command:

heroku login

but I got a command not found error.

I also do not know the name of the Heroku Toolbelt file that I downloaded, but I assumed it was install.sh but all I see in my current directory is: install.log and install.log.syslog

I also did this command

which heroku

but I got no Heroku in ... message

My question is: how do I install the Heroku Toolbelt? What commands do I use? How do I identify the file that was downloaded in the first place? Any assistance will be appreciated.

share|improve this question
2  
What the the install log file say? (And no, you didn't just download it, you ran it "on the fly" - pay attention to what commands you run, that's pretty much as dangerous as clicking on random .exe files you receive by email if you don't trust the source.) –  Mat Jun 14 '13 at 11:47

2 Answers 2

up vote 2 down vote accepted

Assuming you installed as root/sudo, after installing you get prompted to:

Add the Heroku CLI to your PATH using:
$ echo 'PATH="/usr/local/heroku/bin:$PATH"' >> ~/.profile
Installation complete

So, if you add it to your PATH in ~/.profile, e.g.:

PATH=/usr/local/heroku/bin:$PATH

and restart your session, it should work:

whereis heroku
heroku: /usr/local/heroku /usr/local/heroku/bin/heroku
which heroku
/usr/local/heroku/bin/heroku

and:

heroku login
Enter your Heroku credentials.
Email:
share|improve this answer
1  
@Anthony - make sure you restart your session after modifying ~/.profile. –  don_crissti Jun 14 '13 at 20:36
    
+1 Thank you very much @don_crissti It worked!!! –  Anthony Jun 17 '13 at 15:58
    
when I do whereis heroku I get this result: heroku: /usr/local/heroku. But when I do which heroku I get this: /usr/bin/which: no heroku in (/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/me/bin). When I do heroku login I get this message: -bash: heroku: command not found. –  Anthony Jun 17 '13 at 21:07
1  
Well, have you added /usr/local/heroku/bin to your PATH as instructed ? Also, as I said, you are supposed to install this as root/sudo. It works fine on my machine. –  don_crissti Jun 17 '13 at 21:25

On Centos 6 the profile-file is called .bash_profile (not .profile) Edit your .bash_profile and add the path to heroku to the existing PATH specifier

# User specific environment and startup programs
PATH=$PATH:$HOME/bin:/usr/local/heroku/bin
export PATH

Worked for me!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.