Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

For some reason, when I try to update to a modern version of Linux from Debian 6.0.7 or Ubuntu 10.0.4, I lose most of the resolutions that were available, including the native resolution of the panel I'm trying to run (1366x768). This is on an embedded Atom D525-based board that uses the GMA3150 intel integrated graphics (I think this CPU/Chipset is also used in some netbooks). Basically, everything works fine in either Debian 6.0.7 or Ubuntu 10.04. For reference, here is the relevant section of my Xorg.0.log file indicating that all the modes were detected on the LVDS1 output:

(II) intel(0): Printing probed modes for output LVDS1
(II) intel(0): Modeline "1366x768"x59.9   80.00  1366 1436 1577 1648  768 778 783 810 (48.5 kHz)
(II) intel(0): Modeline "1360x768"x59.8   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync (47.7 kHz)
(II) intel(0): Modeline "1360x768"x60.0   72.00  1360 1408 1440 1520  768 771 781 790 +hsync -vsync (47.4 kHz)
(II) intel(0): Modeline "1024x768"x85.0   94.50  1024 1072 1168 1376  768 769 772 808 +hsync +vsync (68.7 kHz)
(II) intel(0): Modeline "1024x768"x75.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz)
(II) intel(0): Modeline "1024x768"x70.1   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
(II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
(II) intel(0): Modeline "1024x768"x87.0   44.90  1024 1032 1208 1264  768 768 776 817 interlace +hsync +vsync (35.5 kHz)
(II) intel(0): Modeline "832x624"x74.6   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
(II) intel(0): Modeline "800x600"x85.1   56.30  800 832 896 1048  600 601 604 631 +hsync +vsync (53.7 kHz)
(II) intel(0): Modeline "800x600"x72.2   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
(II) intel(0): Modeline "800x600"x75.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
(II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
(II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
(II) intel(0): Modeline "640x480"x85.0   36.00  640 696 752 832  480 481 484 509 -hsync -vsync (43.3 kHz)
(II) intel(0): Modeline "640x480"x72.8   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz)
(II) intel(0): Modeline "640x480"x75.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
(II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
(II) intel(0): Modeline "720x400"x85.0   35.50  720 756 828 936  400 401 404 446 -hsync +vsync (37.9 kHz)
(II) intel(0): Modeline "640x400"x85.1   31.50  640 672 736 832  400 401 404 445 -hsync +vsync (37.9 kHz)
(II) intel(0): Modeline "640x350"x85.1   31.50  640 672 736 832  350 382 385 445 +hsync -vsync (37.9 kHz)

After upgrading to Debian 7.0.0 (wheezy), I no longer have most of these resolutions available. At startup, probing for modes looks like this in Xorg.0.log:

[    32.415] (II) intel(0): Printing probed modes for output LVDS1
[    32.415] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz P)
[    32.415] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[    32.415] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[    32.415] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)

This isn't just a Debian issue either, since the exact same thing happens going from Ubuntu 10.04 to 12.04. Debian 6.0.7 includes version 2.13.0 of the intel graphics driver, while 7.0.0 includes version 2.19.0. Is it possible that there's a bug in the driver that causes these modes to not be detected, and if so, is it feasible to just run the old driver or would that break everything? Or has anyone else experienced a similar issue and found a work-around? Trying to manually set the modeline for 1366x768 in Debian 7 results in an error message as follows:

xrandr --newmode "1366x768_60" 80.0 1366 1436 1577 1648  768 778 783 810
xrandr --addmode LVDS1 1366x768_60
X Error of failed request:  BadMatch (invalid parameter attributes)
   Major opcode of failed request:  140 (RANDR)
   Minor opcode of failed request:  18 (RRAddOutputMode)
   Serial number of failed request: 27
   Current serial number in output stream:  28
share|improve this question
    
The custom EDID stuff on the Arch Wiki may help. Not an answer because I'm guessing. –  derobert Jun 13 '13 at 16:11
    
Thanks, I'll look into that. I really don't see why a custom EDID would be needed though, since clearly all the proper resolutions are detected on the old version of Debian. And I also looked for anything resembling an error message in getting all the EDID data in Debian 7, and I see no errors... it just doesn't detect all the resolutions. –  ScottG Jun 14 '13 at 19:52
    
That's a possible workaround. There is probably a bug in the kernel Intel video driver that needs fixing too. You could also try turning off kernel mode setting as another possible workaround. –  derobert Jun 14 '13 at 20:16
    
Have you tried running Xorg -configure; cp ~/xorg.conf.new /etc/X11/xorg.conf ? –  SHW Dec 19 '13 at 7:26

2 Answers 2

I have had the same issue with a computer at work. The issue is with the Intel legacy driver and chip sets compatibility with Linux KMS.

According to Intel Support of Chip sets Intel® Atom™ Processor Z500 Series with Intel® Graphics Media Accelerator 500 is no longer supported on Linux. The issue is with KMS (Kernel Mode Setting) is not working with your graphics chip. That is why those higher resolution is no longer available.

Solution sort of :

  • Need to edit GRUB2 and Disable KMS on boot up Debian Instructions
  • Use XOrg's tool, xrandr (Command line only) or my preferred tool ARandR (Graphical). (Sorry only can post two links so can't add links to the tools)
  • See what your highest resolution that is avilable
  • Your highest resolution will vary on your non-KMS settings. The best I can do on my work machine is 1280x1028 set with GRUB2.
  • Edit GRUB2 to boot to that resolution with disabled KMS.

Things I tried:

  1. Extracted the EDID from Windows
  2. Created a custom EDID
  3. Tried to figure out everything about KMS to see if there was a way to manual make a custom hack to get it to work.
  4. Compiling the Intel Legacy Driver

  5. Bashing head against a wall

share|improve this answer

If you know that resolution is supported you can force the resolution in your commands by putting a # sign in front of them like this.>

your_account$ # xrandr --addmode LVDS1 1366x768_60
share|improve this answer
    
In all the shells I know, that would just turn the command into a comment and not process it at all. –  Ramón Oct 16 at 7:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.