Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After an dist-upgrade within Debian unstable (amd64) I can not use 32 bit programs anymore, because ia32-libs is not possible to install:

# apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-i386
E: Unable to correct problems, you have held broken packages.

# apt-get install ia32-libs-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ia32-libs-i386:i386 : Depends: libcups2:i386 (>= 1.4.4-7+squeeze1) but it is not going to be installed
                       Depends: libcurl3:i386 (>= 7.21.0-2) but it is not going to be installed
                       Depends: libgssapi-krb5-2:i386 (>= 1.8.3+dfsg-4squeeze2) but it is not going to be installed
                       Depends: libk5crypto3:i386 (>= 1.8.3+dfsg-4squeeze2) but it is not going to be installed
                       Depends: libkrb5-3:i386 (>= 1.8.3+dfsg-4squeeze2) but it is not going to be installed
                       Depends: libkrb5support0:i386 (>= 1.8.3+dfsg-4squeeze2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What can I do, to run e.g. google-earth?

share|improve this question

1 Answer 1

Debian is multiarch for a while now (especially sid). You can just install the 32bit libraries directly by adding i386 as a architecture to your system. See the release notes for Debian wheeze for details. In short:

dpkg --add-architecture i386
apt-get update
share|improve this answer
1  
I use multiarch and it was running until 2 weeks ago or so –  Micha Jun 12 '13 at 9:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.