Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I boot up my Fedora 18, I got this message > [1.817675] hub 2-1:1-0: over-current condition on port 1 shown on the screen. Right after the Fedora logo disappear, and it is not yet boot into Fedora.

I was stuck now since I could not do anything, could anyone please advice what should I do for this problem? Before this issue was happened, I just download the necessary development package for LibreOffice using this command > su -c 'yum-builddep libreoffice', I hope this is not the root cause of the problem.

share|improve this question
add comment

2 Answers 2

It sounds like a USB device is trying to draw too much current. Has nothing to do with LibreOffice. You may be able to see the message again with dmesg.

lsusb -v will show each device and their power draws. That should find it for you.help you track it down!

share|improve this answer
    
I was not in the console, and not able to type any input command. –  huahsin68 Jun 10 '13 at 1:13
1  
Unplug every USB device except the keyboard. –  Aaron D. Marasco Jun 10 '13 at 10:13
add comment

I found this thread from the lkml.org mailing list (Linux Kernel Mailing List):

Subject Re: Weird USB over-current messages in recent kernels...

Hello.

Alan Stern wrote:

Seen during boot the last few days on my laptop:

running 3.0.0-rc4-mmotm0622: Jul 2 13:08:37 turing-police kernel: [ 2.788108] hub 2-0:1.0: over-current condition on port 1

... ...

That message was added recently, which may explain why you haven't seen it before.

Wasn't there a similar dev_err() message before that patch that added this message (the previous message was printed on any over-current signal change)?

For more debugging, please collect a usbmon log for bus 2 or bus 6 (see Documentation/usb/usbmon.txt). In fact, you might try doing this for an earlier kernel as well.

It may be that your host controllers claim that an over-current condition exists when it really doesn't, or it may be that those ports are wired incorrectly and really do have an over-current condition.

If it's EHCI driver, there's module option to suppress over-current checking, called 'ignore_oc'. It should help with bogus over-current signalling...

So if you determine that the message is benign you can disable it using the ignore_oc option.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.