Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My Internet connection seems to be extremely slow on loading pages, specifically (it appears) when the browser sends the request for the first time. It takes like 5-6 seconds just to send the request and read the response back.

I don't think there are problems with the router, since the problem appeared only after a system reinstall (ArchLinux) and I probably misconfigured something.

How can I indentify the bottleneck here? The problem seems to be appearing only with the browser (Chromium). Also, what's strange is that my Ethernet interface, which was eth0, now (after the reinstall) is enp2s0. Another thing that is strange is that localhost is not reachable (but I set up a server behind it):

Chromium's connection attempt to localhost was rejected. The website may be down, or your network may not be properly configured.

but localhost:8001 can be reached without any problems.

I suspect the problem is the last Chromium suggested, i.e. a misconfigured network. What can I do to diagnose it?

Here is the contents of /etc/resolv.conf:

# Generated by resolvconf
nameserver 192.168.0.1

EDIT: The problem seems to be DNS lookup. What do you suggest? Should I look into Google DNS?

share|improve this question
    
Check your DNS settings and /etc/nsswitch.conf –  schaiba Jun 5 '13 at 14:06
    
Have a look at tools > developer tools > network. That shows you what the delay results from. –  Hauke Laging Jun 5 '13 at 14:10
    
@schaiba: Unfortunately I cannot interpret what's inside /etc/nsswitch.conf, even with the help of some online resources. I pasted it here anyway: pastebin.com/Gr7n78PX –  rubik Jun 5 '13 at 15:18
    
@HaukeLaging: Thanks, did that. As schaiba suggested it is really probable that the problem is the DNS lookup, as it shows that to load stackexchange.com it took 8.35 s, 8 of which were due to DNS lookup. –  rubik Jun 5 '13 at 15:20
    
Please paste the contents of /etc/resolv.conf –  schaiba Jun 5 '13 at 22:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.