Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to force my wifi card to connect over the G-band as per this question. However, when I run iwconfig, I am told the resource is busy:

[root@Eiger ~]# iwconfig wlan0 freq 2.422G
SET failed on device wlan0 ; Device or resource busy

I'm pretty sure this is because NetworkManager is running. However, when I try to stop it, it just respawns again. I've tried stopping it through systemctl stop and kill. How can I permanently turn off NetworkManager in Gnome 3?

share|improve this question
1  
Try disabling it too: systemctl disable NetworkManager. –  don_crissti Jun 4 '13 at 14:50
    
This only affect whether the process is started upon boot. Is there away to turn it off without rebooting? –  drs Jun 4 '13 at 15:11
    
How about "chkconfig Networkmanager off" –  Salton Jun 4 '13 at 15:48
1  
@drs - try this: stop & disable also NetworkManager-wait-online.service. After disabling both, backup then remove this file: /usr/share/dbus-1/system-services/org.freedesktop.NetworkManager.service. Finally, open /usr/lib/systemd/system/NetworkManager.service and comment out: Alias=dbus-org.freedesktop.NetworkManager.service (e.g. #Alias=...). –  don_crissti Jun 4 '13 at 17:26
    
@don_crissti Nice. That did it. –  drs Jun 5 '13 at 15:33
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.