Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been using Ubuntu 10.10, and the major problem was the wifi, which was not working at all. It worked in Ubuntu 9.10. So after many futile attempts I decided run a Live CD of Ubuntu 9.10, and then wifi worked. Then after restarting I was amazed to see that the wifi was now working in ubuntu 10.10. What could be the reason? I tried lot of things, like blacklisting ath5k, but nothing worked out. Now after doing the Live CD, it's working.

share|improve this question
I don't know what's happening, but I'm giving you the best congratulations! – phunehehe Feb 22 '11 at 9:01
I don't know what fixed your problem but these things happen with wlan cards. For example I turned it off once with the hotkey and it worked so well I couldn't turn it back on again. Then I fixed it from windows. Must be black magic. :) – stribika Feb 22 '11 at 12:33
by any chance did you ever check dmesg (or the kernel logs) when it was failing to work? or have any kind of info for us besides, it didn't work before now it does. what's the output of lspci or lshw for the card? we don't even know what you're running. For all I know the livecd was the first time you tried a reboot. – xenoterracide Feb 22 '11 at 14:24

Some hardware needs to be initialized before it can work. The initialization is good until the hardware is turned off, so you can boot to an OS with a fully working driver, then perform a warm reboot to a second OS with a partially-working driver, and use the device in the second OS.

Often the initialization consists of loading the proper firmware. What may have happened (I know the phenomenon exists but I don't know if your device is an example of it) is that the firmware was illegal to redistribute, and so was excluded from later Ubuntu releases, but is still present in 9.10 (either because you grabbed it before it went away or because no one cared to remove it from the earlier version). Of course, another possible explanation is a bug in the initialization code in the newer driver.

(Yet another hypothesis is buggy hardware that only works when it's hot enough… That's rare but possible.)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.