Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an OpenBSD 5.3 amd64 installed and Intel WiFi Link 1000 card which works with WEP but I obtain a strange message with WPA keys:

# sh /etc/netstart iwn0 
iwn0: no link ............. sleeping

# dhclient iwn0
iwn0: no link ............. sleeping

configuration :

# cat /etc/hostname.iwn0                                            
dhcp nwid Livebox-5dxx wpakey xxxxxxxxxxxxxxxxxxxxxxxxxx
# cat /etc/mygate
192.168.1.1 // Correct I check

Result with ifconfig :

# ifconfig iwn0
iwn0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
lladdr 74:e5:0b:c6:xx:xx
priority: 4
groups: wlan
media: IEEE802.11 autoselect (DS1 mode 11g)
status: no network
ieee80211: nwid Livebox-5dxx chan 6 bssid 00:19:70:a5:xx:xx 222dB wpakey 0x620f88c77fc3866ac2165966050980e5cc18f2a606c84b680c62xxxxxxxxxxxx wpaprotos wpa1,wpa2 wpaakms psk wpaciphers tkip,ccmp wpagroupcipher tkip
inet6 fe80::76e5:bff:fec6:d914%iwn0 prefixlen 64 scopeid 0x2

I would like to know how to debug this configuration.

Is it normal that my WPA key appear in hex with prefix 0x in ifconfig output?

How do I ensure that my WPA key settings are correct?

share|improve this question

2 Answers 2

1 - You could follow this other answer to edit your /etc/hostname.iwn0 and add the wpapsk parameter

Automatic internet connection on startup in OpenBSD?

2 - The Hex key is calculated based on your network id, and wpa passphrase(wpa-psk). Try this site, is very usefull:

http://jorisvr.nl/wpapsk.html

Check if the Hex Key calculated on this site is the same provided by ifconfig. If not, additional debug could be needed

share|improve this answer

Looks like you are missing the wpa keyword in your hostname.iwn0.

You have:

dhcp nwid Livebox-5dxx wpakey xxxxxxxxxxxxxxxxxxxxxxxxxx

I think it should be:

dhcp nwid Livebox-5dxx wpa wpakey xxxxxxxxxxxxxxxxxxxxxxxxxx

It's normal for it to report the wpakey as 0xabcdef..... ifconfig allows you to specify a passphrase as a convenience to you. It converts it into a hex string for you.

share|improve this answer
    
wpa is not needed if there is wpakey, it is written in the manpage. well i think you have compatibility problem. i have had problem with various APs which were used happily by Windows users. Have you tried to associate to different wpa AP? –  Jiri Xichtkniha Nov 15 '13 at 9:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.