Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to bind lxterminal to the windows key on my keyboard. The problem is, it only works for key kombination, such as W-r. But I would like to use W only.

I have added the following in to the <keyboard> section of my .config/openbox/lxde-rc.xml

<keybind key="W">
  <action name="Execute">
    <startupnotify>
      <enabled>true</enabled>
      <name>LXterminal</name>
    </startupnotify>
    <command>lxterminal</command>
  </action>
</keybind>

but this does not work. Can somebody please help?

UPDATE: I have just realized, that <keybind key="W"> refers to the W key (capital w), and not to the Windows key. This is illogical, because key combination W-e refers to Windows key + e.

share|improve this question
add comment

1 Answer

It turns out, I have to use Super_L instead of W

<keybind key="Super_L">
  <action name="Execute">
    <startupnotify>
      <enabled>true</enabled>
      <name>LXterminal</name>
    </startupnotify>
    <command>lxterminal</command>
  </action>
</keybind>
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.