Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have tried to install texlive-full with apt-get and the installation stopped due to some errors. Later I removed all folders and files related to texlive, texmf manually. Since then I get the following error while trying to use apt-get install for any package. I have tried apt-get clean, aptitude clean etc. Can someone please help me. I think it is the dpkg which is giving the errors.

I'm using Linux Mint and am new to using Linux. I have pasted the error message below:

Setting up tex-common (3.13) ...
find: `/etc/texmf/texmf.d': No such file or directory
update-language-dat: cannot read /etc/texmf/hyphen.d/00tex.cnf
update-language-dat: if it was removed by accident, it has to be reinstalled with
update-language-dat:   t=$(mktemp -d); cd $t; apt-get download tex-common ; dpkg -i --force-confmiss tex-common*.deb
dpkg: error processing tex-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of latex-sanskrit:
 latex-sanskrit depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing latex-sanskrit (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of tex-gyre:
 tex-gyre depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing tex-gyre (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-latex-base:
 texlive-latex-base depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-latex-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of asymptote:
 asymptote depends on texlive-latex-base; however:
  Package texlive-latex-base is not configured yet.
 asymptote depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing asymptote (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of context:
 context depends on tex-gyre; however:
  Package tex-gyre is not configured yet.
 context depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing context (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of context-modules:
 context-modules depends on context (>> 2011); however:
  Package context is not configured yet.
 context-modules depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing context-modules (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ipe:
 ipe depends on texlive-latex-base; however:
  Package texlive-latex-base is not configured yet.

dpkg: error processing ipe (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-latex-recommended:
 texlive-latex-recommended depends on texlive-latex-base (>= 2012.20120516); however:
  Package texlive-latex-base is not configured yet.
 texlive-latex-recommended depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-latex-recommended (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-xcolor:
 latex-xcolor depends on texlive-latex-recommended; however:
  Package texlive-latex-recommended is not configured yet.
 latex-xcolor depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing latex-xcolor (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of pgf:
 pgf depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
 pgf depends on texlive-latex-recommended; however:
  Package texlive-latex-recommended is not configured yet.
 pgf depends on latex-xcolor (>= 2.00-1); however:
  Package latex-xcolor is not configured yet.

dpkg: error processing pgf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-beamer:
 latex-beamer depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.
 latex-beamer depends on pgf (>= 1.00-1); however:
  Package pgf is not configured yet.
 latex-beamer depends on latex-xcolor (>= 2.00-1); however:
  Package latex-xcolor is not configured yet.
 latex-beamer depends on texlive-latex-base; however:
  Package texlive-latex-base is not configured yet.

dpkg: error processing latex-beamer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-cjk-chinese-arphic-bkai00mp:
 latex-cjk-chinese-arphic-bkai00mp depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing latex-cjk-chinese-arphic-bkai00mp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-cjk-chinese-arphic-bsmi00lp:
 latex-cjk-chinese-arphic-bsmi00lp depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing latex-cjk-chinese-arphic-bsmi00lp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-cjk-chinese-arphic-gbsn00lp:
 latex-cjk-chinese-arphic-gbsn00lp depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing latex-cjk-chinese-arphic-gbsn00lp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-cjk-chinese-arphic-gkai00mp:
 latex-cjk-chinese-arphic-gkai00mp depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing latex-cjk-chinese-arphic-gkai00mp (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of latex-cjk-japanese-wadalab:
 latex-cjk-japanese-wadalab depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing latex-cjk-japanese-wadalab (--configure):
 dependency problems - leaving unconfigured
Setting up m-tx (0.60d-5) ...
warning: kpathsea: configuration file texmf.cnf not found in these directories: /etc/texmf/web2c:/usr/share/texlive/texmf/web2c:/usr/share/texlive/texmf-dist/web2c:/usr/local/share/texmf/web2c.
/var/lib/dpkg/info/m-tx.postinst: 17: /var/lib/dpkg/info/m-tx.postinst: $TEXMFMAIN/web2c/mktexupd: not found
dpkg: error processing m-tx (--configure):
 subprocess installed post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of musixtex:
 musixtex depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing musixtex (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of prosper:
 prosper depends on texlive-latex-base; however:
  Package texlive-latex-base is not configured yet.
 prosper depends on texlive-latex-recommended; however:
  Package texlive-latex-recommended is not configured yet.
 prosper depends on tex-common (>= 1.10); however:
  Package tex-common is not configured yet.

dpkg: error processing prosper (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-ar:
 texlive-doc-ar depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-ar (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-bg:
 texlive-doc-bg depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-bg (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-cs+sk:
 texlive-doc-cs+sk depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-cs+sk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-de:
 texlive-doc-de depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-de (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-en:
 texlive-doc-en depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-en (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-es:
 texlive-doc-es depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-es (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-fi:
 texlive-doc-fi depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-fi (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-fr:
 texlive-doc-fr depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-fr (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-it:
 texlive-doc-it depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-it (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-ja:
 texlive-doc-ja depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-ja (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-ko:
 texlive-doc-ko depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-ko (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-mn:
 texlive-doc-mn depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-mn (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-nl:
 texlive-doc-nl depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-nl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-pl:
 texlive-doc-pl depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-pl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-pt:
 texlive-doc-pt depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-pt (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-rs:
 texlive-doc-rs depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-rs (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-ru:
 texlive-doc-ru depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-ru (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-si:
 texlive-doc-si depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-si (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-th:
 texlive-doc-th depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-th (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-tr:
 texlive-doc-tr depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-tr (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-uk:
 texlive-doc-uk depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-uk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-vi:
 texlive-doc-vi depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-vi (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-zh:
 texlive-doc-zh depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-doc-zh (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-fonts-extra:
 texlive-fonts-extra depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-fonts-extra (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-fonts-extra-doc:
 texlive-fonts-extra-doc depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-fonts-extra-doc (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-fonts-recommended:
 texlive-fonts-recommended depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-fonts-recommended (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-fonts-recommended-doc:
 texlive-fonts-recommended-doc depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-fonts-recommended-doc (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-generic-extra:
 texlive-generic-extra depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-generic-extra (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-humanities-doc:
 texlive-humanities-doc depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-humanities-doc (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-lang-african:
 texlive-lang-african depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-lang-african (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-lang-arabic:
 texlive-lang-arabic depends on tex-common (>= 3); however:
  Package tex-common is not configured yet.

dpkg: error processing texlive-lang-arabic (--configure):
 dependency problems - leaving unconfigured
dpkg: too many errors, stopping
Errors were encountered while processing:
 tex-common
 latex-sanskrit
 tex-gyre
 texlive-latex-base
 asymptote
 context
 context-modules
 ipe
 texlive-latex-recommended
 latex-xcolor
 pgf
 latex-beamer
 latex-cjk-chinese-arphic-bkai00mp
 latex-cjk-chinese-arphic-bsmi00lp
 latex-cjk-chinese-arphic-gbsn00lp
 latex-cjk-chinese-arphic-gkai00mp
 latex-cjk-japanese-wadalab
 m-tx
 musixtex
 prosper
 texlive-doc-ar
 texlive-doc-bg
 texlive-doc-cs+sk
 texlive-doc-de
 texlive-doc-en
 texlive-doc-es
 texlive-doc-fi
 texlive-doc-fr
 texlive-doc-it
 texlive-doc-ja
 texlive-doc-ko
 texlive-doc-mn
 texlive-doc-nl
 texlive-doc-pl
 texlive-doc-pt
 texlive-doc-rs
 texlive-doc-ru
 texlive-doc-si
 texlive-doc-th
 texlive-doc-tr
 texlive-doc-uk
 texlive-doc-vi
 texlive-doc-zh
 texlive-fonts-extra
 texlive-fonts-extra-doc
 texlive-fonts-recommended
 texlive-fonts-recommended-doc
 texlive-generic-extra
 texlive-humanities-doc
 texlive-lang-african
 texlive-lang-arabic
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
1  
"I manually removed" sounds like the time when you messed up to the point where we cannot really help you. I'd love to be proven wrong but this is a recurring anti-pattern which forces us to abandon many reasonable assumptions about how your system is working. –  tripleee Jun 3 '13 at 7:12
    
Luckily the diagnostics suggest some things to try. Have you tried them? –  tripleee Jun 3 '13 at 7:13

1 Answer 1

I removed all folders and files related to texlive, texmf manually

Ouch.

You can try reinstalling these packages. You'll need to force things along. Start by downloading the packages:

apt-get -d --reinstall install texlive texlive-common …

You'll have to list all the packages you messed up. Then unpack them with dpkg.

dpkg --unpack /var/cache/apt/archives/texlive* 

Then try configuring them all:

dpkg --configure -a
apt-get -f install

It's hard to predict whether this will work. If it doesn't work, remove the affected packages and then install them again. You'll have to remove the pre- and post-removal scripts as they're likely to fail.

rm /var/lib/dpkg/texlive*.post*
dpkg -r texlive-common texlive …
apt-get -f install
apt-get install texlive
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.