Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have Linux mint 13(ubuntu 12.04) installed on my thinkpad T520, running for around 1 year. I'm not able to shut down my machine even if I do: sudo shutdown now. At first, it halts after messages of collectmon signal caught and modem-manager signal caught:

signal caught

I uninstalled both programs. Now it halts "my_username login:". If I shutdown right before login, I have this screen:

before login

And it still refuses to shutdown.I suspect it might be a result after I disabled some of the service through boot-up manager. I didn't take notes exactly what I did and neither there were any problems at that moment.

I would like to know what prevents the machine to shut down. Now, I have to press the shut down button every time, which is annoying.

This is the screen capture of the services that are still disabled:

ss of services #1 ss of services #2 ss of services #3 ss of services #4 ss of services #5

The link to the original images is here.

ls /etc/init.d/*net*

/etc/init.d/networking                   /etc/init.d/network-interface-security
/etc/init.d/network-interface            /etc/init.d/network-manager
/etc/init.d/network-interface-container

ls /etc/init.d/acpid

/etc/init.d/acpid

ls /etc/rc0.d/

K01mdm                  K20vboxautostart-service    S20sendsigs
K01tlp                  K20vboxballoonctrl-service  S30urandom
K09apache2              K20vboxdrv                  S31umountnfs.sh
K10unattended-upgrades  K20vboxweb-service          S35networking
K20acpid                K20virtualbox-guest-utils   S40umountfs
K20hddtemp              K20wicd                     S48cryptdisks
K20mbmon                K20winbind                  S59cryptdisks-early
K20network-interface    K80openvpn                  S60umountroot
K20network-manager      K95collectd                 S90halt
K20speech-dispatcher    README
share|improve this question
    
Are you mounting any remote filesystems? Via SMB or NFS or sshfs or anything like that? –  terdon Jun 2 '13 at 14:51
    
I don't think so. dropbox? I do use SSH tunnel for proxy. –  Kevin Q Jun 2 '13 at 16:06
    
Try disconnecting all network interfaces (sudo service networking stop) and then shutting down. Does it still hang? –  terdon Jun 2 '13 at 16:08
    
It doesn't if I do that. –  Kevin Q Jun 3 '13 at 4:03
1  
OK, so the system hangs because it is expecting an answer from the network. We have to figure out why. Are you sure you don't have any remote filesystems mounted? No Windows shares? No NFS? –  terdon Jun 3 '13 at 14:32

3 Answers 3

You might be missing the halt -h option

shutdown -h now

From shutdown's man page:

"shutdown sends a request to the init(8) daemon to bring the system down into the appropriate runlevel."

"-h Requests that the system be either halted or powered off after it has been brought down, with the choice as to which left up to the system."

Bringing the system down and halting it or powering it off are different things.

share|improve this answer
    
Wouldn't shutdown then not know what to do, and thus error out? –  Michael Kjörling Jun 5 '13 at 12:02
    
Not working with shutdown. –  Kevin Q Jun 5 '13 at 13:01

You just need to use poweroff. Some time in the last 3 or 4 releases the upstart maintainers fixed the shutdown command so that it works like Unix. If you want the power to go off, use poweroff, or shutdown -P (these are basically the same thing).

Shutting down into runlevel 0 without halting/powering off is perfectly valid behavior, though not super useful with today's computers (I believe it is a relic of mini computers that sometimes needed a long time to power cycle).

share|improve this answer
    
Not working either. –  Kevin Q Jun 9 '13 at 5:52

This is not really a solution, more like a workaround but you could make shutdown stop networking by making it an alias. Add this to your ~/.bashrc:

alias shutdown='sudo service networking stop && sudo shutdown -h'

That will stop the networking service before it shuts down.

share|improve this answer
    
It doesn't on my system, whether it's before export statement or after. –  Kevin Q Jun 10 '13 at 5:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.