Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

About a month ago I installed the newest version of Linux Mint (14).
I use Linux the whole day on my laptop but every 1-2 hours my internet connection (Wi-Fi) magically disappears for about 10 minutes.
I get this error when I try to open a website in Chrome:

The server at google.com can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network.

There is also no "ping" when I open the terminal.

I also have Windows installed on the same machine, but I never experience issues like this while using Windows.
When the internet is gone on Linux, it's still available on my phone over the same Wi-Fi. So the internet connection itself works perfectly fine.

Does anybody have an idea?

Update:

It's me again. I used Windows for a while, but had to change to Linux again (Ubuntu this time).
The last time, my connection disappeared, I tried the commands, suggested by jasonwryan and Bruce Ediger. These are my results:

$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr ec:f4:bb:5e:3a:24  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:f7c00000-f7c20000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2953 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2953 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:311476 (311.4 KB)  TX bytes:311476 (311.4 KB)

wlan0     Link encap:Ethernet  HWaddr f8:16:54:9d:62:5f  
          inet addr:192.168.178.20  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: fe80::fa16:54ff:fe9d:625f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:218583 errors:0 dropped:0 overruns:0 frame:0
          TX packets:120476 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:299458438 (299.4 MB)  TX bytes:12939161 (12

$ iw dev wlan0 link
Connected to 34:31:c4:67:9b:bc (on wlan0)
    SSID: FRITZ!Box 7312
    freq: 2412
    RX: 183533 bytes (212 packets)
    TX: 15958 bytes (227 packets)
    signal: -57 dBm
    tx bitrate: 115.6 MBit/s MCS 13 short GI

    bss flags:  short-preamble short-slot-time
    dtim period:    1
    beacon int: 100



$ dmesg
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Initializing cgroup subsys cpuacct
[    0.000000] Linux version 3.16.0-28-generic (buildd@komainu) (gcc version 4.9.1 (Ubuntu 4.9.1-16ubuntu6) ) #37-Ubuntu SMP Mon Dec 8 17:15:28 UTC 2014 (Ubuntu 3.16.0-28.37-generic 3.16.7-ckt1)
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-28-generic root=UUID=250ef3c4-35b0-4318-aac8-d6855bf852b1 ro quiet splash vt.handoff=7
[    0.000000] KERNEL supported cpus:
[    0.000000]   Intel GenuineIntel
[    0.000000]   AMD AuthenticAMD
[    0.000000]   Centaur CentaurHauls
[    0.000000] e820: BIOS-provided physical RAM map:
[    0.000000] BIOS-e820: [mem 0x0000000000000000-0x00000000000913ff] usable
[    0.000000] BIOS-e820: [mem 0x0000000000091400-0x000000000009ffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000000e0000-0x00000000000fffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000000100000-0x00000000cefe4fff] usable
[    0.000000] BIOS-e820: [mem 0x00000000cefe5000-0x00000000cefebfff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000cefec000-0x00000000cf9e1fff] usable
[    0.000000] BIOS-e820: [mem 0x00000000cf9e2000-0x00000000cfeaafff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000cfeab000-0x00000000d7db3fff] usable
[    0.000000] BIOS-e820: [mem 0x00000000d7db4000-0x00000000d7ffffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000d8000000-0x00000000d8758fff] usable
[    0.000000] BIOS-e820: [mem 0x00000000d8759000-0x00000000d87fffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000d8800000-0x00000000d8f99fff] usable
[    0.000000] BIOS-e820: [mem 0x00000000d8f9a000-0x00000000d8ffffff] ACPI data
[    0.000000] BIOS-e820: [mem 0x00000000d9000000-0x00000000da71bfff] usable
[    0.000000] BIOS-e820: [mem 0x00000000da71c000-0x00000000da7fffff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x00000000da800000-0x00000000dbcf6fff] usable
[    0.000000] BIOS-e820: [mem 0x00000000dbcf7000-0x00000000dbffffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000dd000000-0x00000000df1fffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000f8000000-0x00000000fbffffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fec00000-0x00000000fec00fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fed00000-0x00000000fed03fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fed1c000-0x00000000fed1ffff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000fee00000-0x00000000fee00fff] reserved
[    0.000000] BIOS-e820: [mem 0x00000000ff000000-0x00000000ffffffff] reserved
[    0.000000] BIOS-e820: [mem 0x0000000100000000-0x000000021edfffff] usable
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] SMBIOS 2.7 present.
[    0.000000] DMI: Dell Inc. Latitude E5540/0H56PP, BIOS A06 05/01/2014
[    0.000000] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
[    0.000000] e820: remove [mem 0x000a0000-0x000fffff] usable
[    0.000000] AGP: No AGP bridge found
[    0.000000] e820: last_pfn = 0x21ee00 max_arch_pfn = 0x400000000
[    0.000000] MTRR default type: uncachable
[    0.000000] MTRR fixed ranges enabled:
[    0.000000]   00000-9FFFF write-back
[    0.000000]   A0000-BFFFF uncachable
[    0.000000]   C0000-DBFFF write-protect
[    0.000000]   DC000-E7FFF uncachable
[    0.000000]   E8000-FFFFF write-protect
[    0.000000] MTRR variable ranges enabled:
[    0.000000]   0 base 0000000000 mask 7E00000000 write-back
//TOO LONG

The content of /etc/resolv.conf is:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1
search fritz.box

Neither journalctl | tail nor /var/log/messages were found.

share|improve this question
1  
+1 for the title. –  paraxor Jun 2 '13 at 1:45
1  
Look in /etc/resolv.conf when your connection is up and then, when it goes down, check again... –  jasonwryan Jun 2 '13 at 3:44
    
After a while a added some updates. –  user1170330 Dec 11 at 21:32

1 Answer 1

up vote 0 down vote accepted

When this happens (during the 10 minutes of no Internet), run a few commands in a terminal window, as the root user or using sudo:

ifconfig -a - look for output concerning wlan0

iw dev wlan0 link

dmesg

journalctl | tail or if journalctl doesn't exist, look in /var/log/messages

Something in that output should give you more to go on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.