Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I run Debian 7 on an HP nc4400 laptop. This is an old laptop with an Intel Centrino chipset. It runs fine except that the fan turns on for 10 seconds, then off for 20 seconds and then on for 10 seconds, and so on.

The BIOS doesn't say anything on ACPI or APM. dmesg | grep -i "acpi" returns this:

0317)
[    0.229900] ACPI: Dynamic OEM Table Load:
[    0.229904] ACPI: SSDT   (null) 001FB (v01 HP      Cpu0Ist 00003000 INTL 20060317)
[    0.230045] ACPI: SSDT 7f7f629b 004CB (v01 HP      Cpu0Cst 00003001 INTL 20060317)
[    0.230435] ACPI: Dynamic OEM Table Load:
[    0.230439] ACPI: SSDT   (null) 004CB (v01 HP      Cpu0Cst 00003001 INTL 20060317)
[    0.230701] ACPI: SSDT 7f7f5f53 000C8 (v01 HP      Cpu1Ist 00003000 INTL 20060317)
[    0.231101] ACPI: Dynamic OEM Table Load:
[    0.231105] ACPI: SSDT   (null) 000C8 (v01 HP      Cpu1Ist 00003000 INTL 20060317)
[    0.231211] ACPI: SSDT 7f7f6216 00085 (v01 HP      Cpu1Cst 00003000 INTL 20060317)
[    0.231603] ACPI: Dynamic OEM Table Load:
[    0.231606] ACPI: SSDT   (null) 00085 (v01 HP      Cpu1Cst 00003000 INTL 20060317)
[    0.244084] ACPI: Interpreter enabled
[    0.244100] ACPI: (supports S0 S3 S4 S5)
[    0.244121] ACPI: Using IOAPIC for interrupt routing
[    0.244789] PCI: MMCONFIG at [mem 0xf8000000-0xfbffffff] reserved in ACPI motherboard resources
[    0.245206] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    0.260264] ACPI: Power Resource [C220] (on)
[    0.262871] ACPI: Power Resource [C228] (on)
[    0.269881] ACPI: Power Resource [C329] (off)
[    0.269959] ACPI: Power Resource [C32A] (off)
[    0.270035] ACPI: Power Resource [C32B] (off)
[    0.270113] ACPI: Power Resource [C32C] (off)
[    0.270888] ACPI: EC: GPE = 0x16, I/O: command/status = 0x66, data = 0x62
[    0.271132] ACPI: No dock devices found.
[    0.271142] PCI: Ignoring host bridge windows from ACPI; if necessary, use "pci=use_crs" and report a bug
[    0.274594] ACPI: PCI Root Bridge [C002] (domain 0000 [bus 00-ff])
[    0.283058] pci 0000:00:1f.0: quirk: [io  0x1000-0x107f] claimed by ICH6 ACPI/GPIO/TCO
[    0.285079] ACPI: PCI Interrupt Routing Table [\_SB_.C002._PRT]
[    0.285255] ACPI: PCI Interrupt Routing Table [\_SB_.C002.C098._PRT]
[    0.285357] ACPI: PCI Interrupt Routing Table [\_SB_.C002.C101._PRT]
[    0.285421] ACPI: PCI Interrupt Routing Table [\_SB_.C002.C111._PRT]
[    0.285491]  pci0000:00: Requesting ACPI _OSC control (0x1d)
[    0.285495]  pci0000:00: ACPI _OSC request failed (AE_NOT_FOUND), returned control mask: 0x1d
[    0.285498] ACPI _OSC control for PCIe not granted, disabling ASPM
[    0.298542] ACPI: PCI Interrupt Link [C10D] (IRQs *10 11)
[    0.298640] ACPI: PCI Interrupt Link [C10E] (IRQs *10 11)
[    0.298735] ACPI: PCI Interrupt Link [C10F] (IRQs 10 *11)
[    0.298829] ACPI: PCI Interrupt Link [C110] (IRQs 10 11) *5
[    0.298923] ACPI: PCI Interrupt Link [C123] (IRQs *10 11)
[    0.299016] ACPI: PCI Interrupt Link [C124] (IRQs *10 11)
[    0.299110] ACPI: PCI Interrupt Link [C125] (IRQs 10 *11)
[    0.299152] ACPI Exception: AE_NOT_FOUND, Evaluating _PRS (20110623/pci_link-184)
[    0.299282] PCI: Using ACPI for IRQ routing
[    0.306278] pnp: PnP ACPI init
[    0.306293] ACPI: bus type pnp registered
[    0.306470] system 00:00: Plug and Play ACPI device, IDs PNP0c01 (active)
[    0.310002] pnp 00:01: Plug and Play ACPI device, IDs PNP0a08 PNP0a03 (active)
[    0.310352] pnp 00:02: Plug and Play ACPI device, IDs IFX0102 PNP0c31 (active)
[    0.310415] pnp 00:03: Plug and Play ACPI device, IDs PNP0c04 (active)
[    0.310472] pnp 00:04: Plug and Play ACPI device, IDs PNP0200 (active)
[    0.310520] pnp 00:05: Plug and Play ACPI device, IDs PNP0800 (active)
[    0.310576] pnp 00:06: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.310690] pnp 00:07: Plug and Play ACPI device, IDs PNP0103 (active)
[    0.310749] pnp 00:08: Plug and Play ACPI device, IDs PNP0303 (active)
[    0.310804] pnp 00:09: Plug and Play ACPI device, IDs SYN010f SYN0100 SYN0002 PNP0f13 (active)
[    0.311066] system 00:0a: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.311677] pnp 00:0b: Plug and Play ACPI device, IDs HPQ0004 (active)
[    0.311845] system 00:0c: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.312175] system 00:0d: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.312190] pnp: PnP ACPI: found 14 devices
[    0.312192] ACPI: ACPI bus type pnp unregistered
[    0.312197] PnPBIOS: Disabled by ACPI PNP
[    0.694522] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[    0.694789] acpiphp: Slot [1] registered
[    1.209623] ACPI: Thermal Zone [TZ0] (43 C)
[    1.245239] ACPI: Thermal Zone [TZ1] (47 C)
[    1.245347] ACPI: Fan [C32D] (off)
[    1.245425] ACPI: Fan [C32E] (off)
[    1.245503] ACPI: Fan [C32F] (off)
[    1.245582] ACPI: Fan [C330] (off)
[    1.264245] ACPI: Thermal Zone [TZ2] (38 C)
[    1.274458] ACPI: Thermal Zone [TZ3] (27 C)
[    1.278192] ACPI: Thermal Zone [TZ4] (72 C)
[    1.770523] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[    1.782791] ata1.00: ACPI cmd c6/00:10:00:00:00:a0 (SET MULTIPLE MODE) succeeded
[    1.782796] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[    1.830495] ata1.00: ACPI cmd f5/00:00:00:00:00:a0 (SECURITY FREEZE LOCK) filtered out
[    1.842790] ata1.00: ACPI cmd c6/00:10:00:00:00:a0 (SET MULTIPLE MODE) succeeded
[    1.842794] ata1.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[    2.559585] ACPI: Requesting acpi_cpufreq
[    2.573303] ACPI: Sleep Button [C249]
[    2.573433] ACPI: Lid Switch [C241]
[    2.578133] ACPI: acpi_idle registered with cpuidle
[    2.579241] ACPI: Power Button [PWRF]
[    2.608481] ACPI: AC Adapter [C1B2] (on-line)
[    2.619330] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[    2.620666] acpi device:01: registered as cooling_device6
[    2.620899] ACPI: Video Device [C085] (multi-head: yes  rom: no  post: no)
[    2.669097] ACPI: Battery Slot [C1B4] (battery present)
[    2.669211] ACPI: Battery Slot [C1B3] (battery absent)
[    3.865996] snd_hda_intel 0000:00:1b.0: power state changed by ACPI to D0
[    3.866008] snd_hda_intel 0000:00:1b.0: power state changed by ACPI to D0
[    7.577461] input: ACPI Virtual Keyboard Device as /devices/virtual/input/input11

I ran lm_sensors and had it add a line to a config file I don't really remember - but it didn't help.

(Edit: it added 'loop' and 'coretemp' to /etc/modules and had me restart a service to effectuate it.)

I can have the fan turned on permanently from the BIOS when running on AC power but I'd rather I would turn on or off when necessary, not constantly on and off every 10-20 seconds.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.