Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used to be able to connect to my Gnome 3 desktop from a Windows machine with a VNC client. But after an upgrade (on the Linux side) a while ago, it quit working. When I attempt to connect, all I can get is a message saying "No matching security types" or "No supported authentication methods!" (depending on which client I try).

In Gnome 3, I've turned on Screen Sharing under Settings > Sharing. Under that, I have Remote View on, Remote Control on, Approve All Connections on, Require Password off. I'm running Arch Linux with vino 3.8.1.

On the Windows side, I've tried TigerVNC 1.0.1 & 1.2.0 and UltraVNC 1.0.9.6.2.

How can I get this working?

share|improve this question
    
Is your firewall disabled and/or configured to allow VNC traffic through to the server? – slm Jun 1 '13 at 17:11
1  
@slm, I don't believe it's a firewall issue, because I don't think you get that error unless the client has successfully opened a connection to the server and asked it what authentication methods it supports. – cjm Jun 1 '13 at 17:14
    
Can you connect to the VNC server using a VNC client from something other than a Windows computer? Just trying to eliminate another variable. Also what version of Windows are we dealing with? – slm Jun 3 '13 at 0:27
up vote 14 down vote accepted

This is actually a known and currently open bug. However, there is a very easy workaround; just issue the following command:

gsettings set org.gnome.Vino require-encryption false

You will now be able to connect with most vnc viewers.

share|improve this answer
    
Yes! This was it. Thanks! – cjm Jul 26 '13 at 20:08
    
After setting this do I need to restart vino-server or anything? I have just tried this and get the same error. – fostandy Sep 3 '14 at 12:50
1  
This is a user level setting, so, if you're still have trouble after changing it, make sure you didn't run it with sudo. – Ryan J Mar 30 '15 at 6:01

Here are some other possible solutions:

  1. Disable Vino encryption, and then setup an SSH tunnel
  2. Use a VNC client compatible with Vino's TLS version: Android: bVNC Free, Windows: SSVNC, Linux: vinagre
  3. Use a different VNC server, such as tigervnc or x11vnc
  4. Use a different VNC server, such as tightvnc, with a different desktop manager, such as MATE, Xfce, LXDE, etc.

Even 2.5 years later, this is still an issue with Fedora, Redhat, and Debian systems... Basically, Gnome 3 does a 3D drive check when starting up gnome-session, which causes it to crash vncserver when NOT using Vino; so, use a different desktop manager. Alternatively, you use Vino, and then are required to either use Type 18 TLS and a handful of compatible VNC viewers, or turn off encryption and have all you traffic be easily sniffed; so, turn off encryption and use an SSH tunnel.

It's a convoluted problem that requires the coordination of multiple groups of developers to solve, and very little progress has been made.

share|improve this answer

I think this question covers all alternative methods and suggestions how to connect to Gnome throught VNC if built-in desktop sharing does not work: Enable remote desktop for Gnome from command line?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.