Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to debug a buggy wireless card and would like to force my Linux computer to connect using one of the g-band channels. How can I achieve this?

share|improve this question

1 Answer 1

'G-Band channels' are the same as b/n. If you want to connect using G only you could use iwconfig like so iwconfig eth0 freq 2.422G

share|improve this answer
    
I've disabled NetworkManager, but whenever I run this command (on the wlan0 interface), I get SET failed on device wlan0 ; Device or resource busy. Is there a way to find out what's keeping it busy? –  drs Jun 4 '13 at 20:22
    
I believe you just don't have permission to execute that command. I found adding "sudo" in front worked for me "sudo iwconfig wlan0 freq 2.412" executed without that error. –  Lucas yesterday

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.