Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Consider I am on server1 logged in as a non-root user. How do I check if a NAS FS has been exported onto the server SERVER1?

I have already tried the below commands.

bash-3.2$ dfshares  SERVER1
nfs dfshares:SERVER1: RPC: Program not registered
bash-3.2$ showmount -e  SERVER1
showmount: SERVER1: RPC: Program not registered
bash-3.2$
bash-3.2$ cat  /etc/dfs/sharetab
bash-3.2$ share
bash-3.2$ cat  /etc/vfstab # No root access
cat: cannot open /etc/vfstab
share|improve this question

1 Answer 1

up vote 4 down vote accepted

On Solaris, non-root users should be able to see NFS exports coming from other servers:

[oracle@webfocus oracle]$ showmount -e ditirlns01
export list for ditirlns01:
/srv/adminMisc      *
/srv/adminScripts   *
/srv/automatedEmail *
/export/idmgr       xxx.xxx.25.107
[oracle@webfocus oracle]$ uname -a
SunOS webfocus.ncat.edu 5.9 Generic_117171-07 sun4u sparc SUNW,Sun-Fire-280R
[oracle@webfocus oracle]$

"Program Not Registered" just means that the client tried to connect to the given server, successfully connected to the part that's supposed to provide ONC RPC services, but that the ONC service responded back that it didn't have a program registered with it to provide the requested service (in this case NFS version whatever). For example, I get this even as root if I query a Linux server that's running portmap but none of the NFS services:

[root@webfocus root]# showmount -e ditirlns03
showmount: ditirlns03: RPC: Program not registered
[root@webfocus root]#

Just for completeness, this is the error for not being able to connect to the RPC server at all:

[root@webfocus root]# showmount -e ditirlns03
showmount: ditirlns03: RPC: Rpcbind failure - RPC: Unable to receive
[root@webfocus root]# 

Long and short of it is: check with the remote server and try to figure out why the NFS service isn't registering with the ONC RPC server.

share|improve this answer
    
Tailing the logs helps: tail /var/log/messages, for e.g. –  slm May 30 '13 at 19:55
    
Thanks @JoelDavis! This was helpful. Sorry for delay in marking it as correct. –  Kent Pawar Jun 25 '13 at 8:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.