Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
Finished Dependency Resolution
Error: Package: mysql-server-5.5.31-1.el6.remi.i686 (remi)
           Requires: libz.so.1(ZLIB_1.2.0)

I type yum --enablerepo=remi install mysq and these error appears. I have epel installed already.

share|improve this question
    
In a short, just upgrade centos to 6.4 solve this problem –  jilen May 27 '13 at 5:38
add comment

1 Answer

up vote 1 down vote accepted

fwiw there is a 5.1 mysql-server in the base channel for RHEL (so I know it's going to be in CentOS's repo) can you not use that version? Is there something specific about 5.5 that you were wanting?

Basically, it looks like it's pulling it from a non-standard repo, and this rpm is (for whatever reason) linked against a particular version of libz (1.2.0). I'm showing that the latest version on RHEL/CentOS 6 is 1.2.3-29 so I'm willing to bet that's probably what you have installed (you can verify with rpm -qa zlib though) If you absolutely need this version you have two options:

1) Try to downgrade the package that provides that .so file ("zlib" according to my yum whatprovides */libz.so* but you'll want to verify on your system). Yum is obviously not going to want to prompt you to downgrade unless you explicitly ask it to (otherwise impulsive people would be breaking their systems left and right). It may take some other packages with it, so make sure you review the list before you accept it (if you go this route).

2) Ask whoever maintains this repo to rebuild the RPM without specifying a version (Red Hat is unlikely to change that much within a major release of RHEL, that's part of what the enterprise customers are paying for) or to re-link against the current 1.2.3 or something. Normally, when a third party repo links against shared libraries coming from the main software channels, they're supposed to update their latest rpm's when those packages get updated (so that it doesn't do this sort of thing). It may be an oversight on their part or the repo could just be old/unmaintained.

share|improve this answer
    
The mysql 5.1 have not utf8mb4 charset, so I had to go for a mysql5.5. And , another centos 6.4 with zlib-1.2.3-29 successfully have mysql 5.5 installed –  jilen May 27 '13 at 5:34
    
What version of zlib is installed on this server? –  Joel Davis May 27 '13 at 5:36
    
Ok, I upgrade the centos to 6.4. Then everything seems fine. –  jilen May 27 '13 at 5:36
    
cool, good to hear –  Joel Davis May 27 '13 at 5:37
    
1.2.3-27 zlib version –  jilen May 27 '13 at 5:37
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.