Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Problem Description - Unable to print

Device name : HP LaserJet M1005 MFP USB printer

OS : Linux 3.8.13-1-MANJARO #1 SMP PREEMPT x86_64 GNU/Linux

Error Description :

  1. Cups is working well and fine.
  2. I am able to access localhost:631
  3. Hplip is installed
  4. Tried to print a PDF file.
  5. After issuing print command, the print queue shows the error "Processing - Not connected?"
  6. Further exploration for the print job error led me to an error "Filter failed"

What I have tried so far :

  • Removed and added the printer through the cups web interface
  • Tried installing the printer using hp-setup under root.

I am not sure what to do at this point. Could someone please tell me what to do or atleast where to look next to have a chance at solving my problem...

share|improve this question
    
Is there anything in /var/log/cups/error_log? –  Gilles May 27 '13 at 21:05
    
I do not have a file called error_log in that directory. I do have a file called error_log.1 in that directory. The contents are a few pages long. I didn't think it would be a good idea to paste the whole thing here, so I have pasted it on pastebin. Here it is link –  Jay May 28 '13 at 15:57
    
Your symptoms could be a sign of a missing proprietary plugin. But the resolution should then be to run hp-setup. What did the setup wizard do? Did it install an additional proprietary driver? Please run hp-check -t and post the output. –  Gilles May 28 '13 at 17:10
    
can you share the output of lpstat -a -v –  Salton May 28 '13 at 22:57
    
@Salton Output of lpstat -a -v is HP_LaserJet_M1005 accepting requests since Wed 29 May 2013 03:44:00 PM IST device for HP_LaserJet_M1005: hp:/usb/HP_LaserJet_M1005?serial=KJ20Y9V –  Jay May 29 '13 at 10:25
show 1 more comment

1 Answer

up vote 2 down vote accepted

I see this line in the logs (/var/log/cups/error_log):

m_Job initialization failed with error = 48

A web search indicates that many HP printers, including yours, require a proprietary plugin to print, and that you will see this message if you haven't install this plugin (e.g. Fedora bug #611255).

The logs from hp-check -t confirm this:

error: Required plug-in status: Not installed

So it seems that you need to install the HPLIP binary plugin. The easy way is to run the hp-setup wizard and enter your printer model, it should install the appropriate plugin, but it doesn't seem to have worked in your case. As hp-check tells you, try hp-doctor, which may find the missing plug-in. If that doesn't work either, run the more basic tool hp-plugin.

share|improve this answer
    
Thanks for your help. I managed to finally get it to work but the procedure was a little different. I tried hp-doctor. Apart from a few missing optional dependencies, there was one missing dependency called hpaio. I use arch linux. Didn't know what package provide the functionality of hpaio. After some searching, I installed sane and modified /etc/sane.d/dll.conf to include the text "hpaio" and "hpoj" in 2 seperate lines. And then, in arch linux ... python points to /usr/bin/python3. hp-doctor needs /usr/bin/python2. I changed linnk and ran hp-doctor again. It worked. –  Jay May 29 '13 at 15:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.