Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'd like to have your advice on yet another pinning problem that hit me recently. I've been through man apt_preferences several times, and I can't find anything wrong in what I did.

I was having kernel panics in Linux Mint Debian Edition (LMDE), when I decided that I wanted to use packages from Debian Wheezy to get a newer kernel that could fix them.

I decided to try with pinning. The plan was to add a deb source for wheezy, and pin it with a very small priority, so that Wheezy packages would be installed only if explicitly requested for. Then, I would install the kernel-image from Wheezy.

I added this source:

deb http://ftp.uninett.no/pub/linux/debian wheezy main contrib non-free

And this pin:

Explanation: Disable Wheezy
Package: *
Pin: origin "ftp.uninett.no"
Pin-Priority: 1

But didn't work. I tried several other approaches like:

Explanation: Disable Wheezy
Package: *
Pin:  release o=Debian,n=wheezy
Pin-Priority: 1

or even

Explanation: Disable Wheezy
Package: *
Pin:  release n=wheezy
Pin-Priority: 1

No matter what, and even with negative priorities, Wheezy packages still had the same priority (500) as the LMDE's, and they were preferred to LMDE's since they were newer.

Can you see anything that I missed so far?

PS: If you're interested in the specific panic problem, you can read the full story here

share|improve this question

migrated from serverfault.com May 25 '13 at 21:24

This question came from our site for professional system and network administrators.

1  
Never used Mint, but did you check /etc/apt/preferences.d/*? The answers here might be relevant: serverfault.com/questions/357052/how-can-i-apt-pin-stable –  cosimo May 8 '13 at 16:04
    
The answer is not completely relevant by itself, and there is nothing in preferences.d, but maybe it pointed me to the right direction: there is a preferences file that I had overlooked. I'll look into that, thanks a bunch! –  bronto May 8 '13 at 17:50
    
You probably should have stuck with Fedora. :) –  Michael Hampton May 25 '13 at 0:31
add comment

1 Answer 1

up vote 0 down vote accepted

I think I found out what the problem was.

The default preferences file looks like this:

Package: *
Pin: release o=linuxmint
Pin-Priority: 700

Package: *
Pin: origin packages.linuxmint.com
Pin-Priority: 700

Package: *
Pin: release o=Debian
Pin-Priority: 500

It seems that the pin "release o=linuxmint" never matches. In fact, I changed it with "origin debian.lth.se" (where debian.lth.se is the LMDE mirror I am using), and there: all the priorities work as expected.

So, this seems to be a bug in LMDE. I'll report it as soon as I can.

share|improve this answer
    
bug reported –  bronto May 25 '13 at 20:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.