Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Currently I can only login to my remote linux via the "ubuntu" user account, without a password (via SSH authentication). I have another user configured on the machine, and if I try to login with its username + password I get

Disconnected: No supported authentication methods available

How do I configure this user to accept user/pass authentication?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

I suspect that your sshd is configured to allow access via public key authentication and to disallow access via password.

There are a couple of thiongs that you can do. The better option is to generate a key-pair for the new account and to copy the public key to your remote host ~/.ssh/authorized_keys file. You can use ssh-keygen or puttygen etc to generate the keys.

Alternatively you can enable sshd password authentication. Edit the /etc/ssh/sshd_config file and ensure that the PasswordAuthentication directive is set to yes

PasswordAuthentication  yes

Save the file and restart sshd and you should then be able to use passwords.

share|improve this answer
    
I'd like to use mRemote as my SSH client, and as far as I can tell, it doesn't support authentication based on key-pairs. This is why I wanted to setup user/pass authentication. –  ripper234 Feb 20 '11 at 12:33
    
I have mRemote configured to use PuTTY as the ssh client. This then allows me to use Pageant to store the keys and login using them. –  Iain Feb 20 '11 at 12:41
    
Cool. Now a followup: superuser.com/questions/248091/… –  ripper234 Feb 20 '11 at 12:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.