Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.
<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/main

    ErrorLog /var/log/apache2/error.log
    # Possible values include: debug, info, notice, warn, error, crit, alert, emerg.
    LogLevel warn
    CustomLog /var/log/apache2/access.log combined

These are my settings in /etc/apache2/sites-enabled/000-default. I have a webserver at home connected via "no-ip" (dynamic dns).

When I try to go on "" I get redirected to the site "" of my ISP.

The basename is dnserror. Nice little, very little, information.

I don't know the mechanics of DNS. Can somebody tell me where the problem is?

Server version: Apache/2.2.22 (Debian)

share|improve this question
Well, it has nothing to do with the Apache configuration at least, because the web server is never reached. For some reason, “” does not resolve. Are you sure there aren’t any typos anywhere? Have you waited for a reasonable time (say, a couple of hours) after setting up the dynamic DNS? –  chirlu May 23 '13 at 12:44

1 Answer 1

up vote 2 down vote accepted

You need to support your “www.” subdomain. You'll need to get the enhanced feature from for it to ever work.

Or alternatively (might be even cheaper), buy your own domain name and make the domain and all the subdomains you want point to your single address.

share|improve this answer
OP could also do what I do: Pay $10 for the domain and use for free. They give you the base domain plus two or three host records for free. Once they're on zonomi, they just make a host record for "www", do the wget magic like on the main domain, and call it good. –  Bratchley May 23 '13 at 13:05
@JoelDavis - good tip, never heard of before. –  slm May 23 '13 at 13:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.