Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the Intel 82845G video card and trying to get X11 working with it. It routinely crashes with artifacts. I know the existing history with this driver and X11 and I am about to buy a replacement video card but decided I will check here first to see if anyone has had any success with it.

I tried it with Linux Mint XFCE, and Crunchbang openbox. I made sure the BIOS onboard video memory is at max, and different options in xorg.conf like disabling DRI.

Eventually I want to use awesome wm. Will changing the wm have any effect on video crashing, or is this solely a problem between Intel's driver and X11 ?

share|improve this question
up vote 0 down vote accepted

I got it working by setting the framebuffer option for the 82845G card to false, disabling Xinerama and running on 1024x768. When I go up to 1024 vertical resolution like on 1280x1024, the video crashes with artifacts frequently, and Xinerama would freeze the system. I only encountered one freeze with artifacts on 1024x768, and that was coming out of standby power mode. If it becomes an issue, I will install another nvidia card as the 8400GS I have works well.

I have two openbox sessions running on two displays and it suits my needs, browser on the left, development on the right. I was worried as I usually have firebug running on my right display, but I'm implementing guard with livereload which should keep the need for full screen firebug minimal. If it's an issue, I will switch to fiddler.

share|improve this answer
Framebuffer option was disabled in xorg.conf. I saw this when having x create the initial config file with # Xorg -configure . Later I may look into using specific intel drivers like i810, but the system seems stable right now so I'm sticking with it. – steve76 Jun 4 '13 at 14:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.