Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Hello I have installed redmine on Arch Linux on my Virtual box and I am successfully able to run my redmine with the help of webrick server.

Now I want to run the same app from the apache with the help of phusion passenger but when I try to run the app it just shows me the directory .

Here is what I have added in my main httpd.conf file:

LoadModule passenger_module /home/moiz/.rvm/gems/ruby-2.0.0-p195@moizgemset/gems/passenger-4.0.2/libout/apach
e2/mod_passenger.so
PassengerRoot /home/moiz/.rvm/gems/ruby-2.0.0-p195@moizgemset/gems/passenger-4.0.2
PassengerDefaultRuby /home/moiz/.rvm/wrappers/ruby-2.0.0-p195@moizgemset/ruby

Here what I have added in my website conf file in /etc/httpd/extra/httpd-redmine.conf:

Alias /redmine "/srv/http/redmine/public"
<Directory "/srv/http/redmine/public">
  Options Indexes MultiViews FollowSymLinks
  AllowOverride All
  Allow from all
</Directory>
ScriptAlias /cgi-bin "/srv/http/cgi-bin"
<Directory "/srv/http/cgi-bin">
  AllowOverride all
  Options ExecCGI FollowSymLinks
  Order allow,deny
  Allow from all
</Directory>
ScriptAlias /redmine-cgi "/srv/http/cgi-bin"
<Directory "/srv/http/cgi-bin">
  AllowOverride all
  Options ExecCGI FollowSymLinks
  Order allow,deny
  Allow from all
</Directory>

Am I missing anything? My Phusion passenger is working and also my apache, as if I run my app in root, I am able to see the default apache page.

enter image description here

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.