Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

when I run dhcpcd after boot everything works fine but when I try to add it to auto start systemctl enable dhcpcd@eth0.service, after each boot it's inactive

dhcpcd@eth0.service       loaded inactive dead      start dhcpcd on eth0
share|improve this question
What happens if you simply do 'systemctl enable dhcpcd' ? – schaiba May 21 '13 at 14:22
the same, symbolic link is created, service starts but it's dead. I run Arch Linux in VirtualBox on Windows 7 if that matters. – micnyk May 21 '13 at 14:44
systemctl status dhcpcd@eth0.service? Shows any error message? – uzsolt May 21 '13 at 15:22
Ohh, I didn't try this command. Yes, it says no such file or directory. – micnyk May 21 '13 at 15:35
@don_crissti: thanks, changing name worked for me ;) – micnyk May 21 '13 at 18:57

2 Answers 2

Maybe the ethernet device name is not eth0. Mine is enp3s0. This varies with the ethernet device.

Hope it helps!

share|improve this answer

systemctl enable dhcpcd.service works for me.

share|improve this answer
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. – jasonwryan Oct 17 at 2:44
@jasonwryan Although you don't think it is an answer, it is the solution to the problem. – eccstartup Oct 18 at 14:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.