Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an issue, and I'm unsure if it is a bug or not but here's the skinny:

I updated cinnamon from 1.6.7 to 1.8 (don't get me wrong, I love it BUT!)

Ever since I did the update, Cinnamon has been freezing on me. The mouse moves, but nothing is click-able (so I can't right click the panel > Troubleshoot > restart cinnamon).
--My mindset for this is that the freezing can be tolerable if I can just restart cinnamon without having to continuously restart my computer about four to six times a day.

I can be in Firefox mid-type, mid-scroll, trying to minimize (one time, froze while trying to maximize), and trying to move the window. I opened up Skype, went to login and it froze. Opened up the Menu and it froze. Right clicked the desktop, tried to pick an option and it froze.

I don't know if it is just me or not, but either way, there is a rather annoying issue on my hands. There were glitches in 1.6.7, but it never froze. And I had the ability to right click the panel to restart Cinnamon to fix the issues then.

Details:

Linux Mint 13 (cinnamon 1.8)
Processor: AMD Turion(tm) 64 X2 Mobile Technology TL-58 x 2
Graphics: Gallium 0.4 on NV4E
OS type: 32 bit

What I've Done So Far

went into tty2 and typed in

export DISPLAY=:0; cinnamon --replace &

The first response I received was

[1] 2940

followed up by

Window manager error: Unable to open X display

(Got the idea from Ubuntu SE and tried all the answers there too, nothing worked. The idea of just hitting 'r' and enter didn't help me restart cinnamon either.)

The last thing I did was completely removed Cinnamon and then reinstalled it:

sudo apt-get --purge remove cinnamon  
sudo apt-get install cinnamon

I restarted my computer, logged in, 5 minutes later, it froze. (:/ didn't help)

Since I don't think I can fix this, is there a way to "roll-back" to 1.6.7.?

share|improve this question
    
Have you tried with a new user account to rule out any config problems ? Also, have you checked your session log for any useful output ? –  don_crissti May 21 '13 at 0:10

2 Answers 2

The following commands should do what you want:

sudo apt-get purge cinnamon
sudo apt-get install cinnamon=1.6.7
gsettings reset-recursively org.cinnamon

If you can't find the packages in your repository you can still download them manually here:

cinnamon 1.6.7+lmde:

Once you download which ever architecture you have you can install it like this:

dpkg -i <cinnamon.deb>
apt-get -fy install

The first command will install your download .deb file, the second will install any dependencies that it might require.

share|improve this answer
    
I thank you, and it was all fine and dandy until version 1.6.7 for cinnamon was not found... so I'm guessing it was taken down or something. But thank you anyway! +1 for the useful answer (in all seriousness, it would have reverted back if 1.6.7 was still there; can't fault you for that) –  Souta May 21 '13 at 0:57
    
Well, I had a dumb moment. I was too busy being concerned that Cinnamon wasn't working right that I completely ignored the fact that the options you gave were for LMDE. I don't have LMDE. But either way, fixed my own issue without having to downgrade. And still, I thank you for trying to help. –  Souta May 22 '13 at 21:44

Had a similar problem with fresh install of Mint 15.

dmesg

shows nouveau error ("fail ttm_validate"). The problem got solved by installing the proprietary nVidia drivers:

sudo apt-get install nvidia-current

If this does not work for you, try

sudo pkill -SIGHUP cinnamon

instead of --replace. This will merely redraw all windows rather than killing them. But browser downloads tend to get prematurely terminated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.