Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I tried using command yum install wireshark-gnome to install wireshark on RedHat 6.3. And I make sure the network is ok. But it fails cause by below prompt.

Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
Setting up Install Process
No package wireshark-gnome available.
Error: Nothing to do

It looks repository of yum does not work. It should not have wireshark installation package. So I try intall new repository as below.

wget http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm

It still does not work. Could you help me to find a usable repository?

share

migration rejected from serverfault.com yesterday

This question came from our site for professional system and network administrators. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

put on hold as off-topic by jasonwryan, Anthon, chaos, garethTheRed, Networker yesterday

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – jasonwryan, Anthon, chaos, garethTheRed, Networker
If this question can be reworded to fit the rules in the help center, please edit the question.

3  
Why do you expect that it would work after adding a random repo that doesn't contain wireshark at all? Have you tried googling for the error message "unable to read consumer identity"? After doing so, I found this: lpar.ath0.com/2012/09/10/yum-unable-to-read-consumer-identity –  SvW May 20 '13 at 9:52
    
Abandoned: voting to close... –  jasonwryan yesterday

2 Answers 2

You can install the wireshark-gnome package from the installation DVD or go to the official wireshark website and download the rpm package. other resolutions are register with RHN or add a EPEL repository to yum and the try.

share

Try installing rpm provided by CentOS/Scientific Linux. You can also search on rpm.pbone.net site. This package may be compatible for your system. Also check availability and install all other Required packages.

share