Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to install later version of software for 2 RPM-based installations, but yum tells me that I already have the latest versions.

When looking to install software via RPM, what's the best way to find it?

share|improve this question
    
What commands have you run thus far? –  slm May 20 '13 at 1:27
    
I searched for OpenSSH 4.4 RPM via www.openssh.org, but I didn't find the RPM when looking through the mirrors' /rpm pages. My colleague has access to the RHEL RPM Network, so I'm not sure if I just need to look there. –  Kevin Meredith May 20 '13 at 1:28
    
If there is a package available, I would expect it to show up in the RHEL RPM Network prior to showing up in other places. Even this assumption is really dependent on the specific package. But in general that's why you pay for RHEL RPM Network. –  slm May 20 '13 at 1:36
add comment

1 Answer

up vote 2 down vote accepted

If yum tells you that the latest packages are already installed, then it is so. What makes you think there are newer packages available?

share|improve this answer
    
On RHEL 5, yum tells me that OpenSSH 4.3 is the latest, however I can go to OpenSSH's webpage and see newer versions of OpenSSH. I assume that the newer versions are also available via RPM. –  Kevin Meredith May 20 '13 at 1:30
    
@Kevin - That assumption isn't a good one. There isn't really any correlation to a new version being available on a particular software's site vs. an RPM being available. –  slm May 20 '13 at 1:33
1  
@Kevin, sit it out. The distribution might have sound reasons not to rush to the next version: Untested, subtle API changes, ... –  vonbrand May 20 '13 at 1:38
1  
@Kevin, Vonbrand is 100% correct. If it isn't available there are probably good reasons. Regression tests need to be performed, the new version might have bug fixes for other OSes, not RHEL, so they may be skipping it. There are really a whole slew of reasons. On such a core package such as OpenSSH, I would leave it up to the distro entirely. –  slm May 20 '13 at 1:40
1  
@slm, the "enterprise" distributions just almost never change the base version of the software they ship (so APIs and so don't change) while backporting fixes very actively. –  vonbrand May 20 '13 at 1:42
show 7 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.