Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I followed these instructions on how to set up my TP-Link TL-WR1043ND as a dumb AP:

  1. Flashed brand new Attitude Adjustment 12.09-rc1
  2. Logged into LuCI, set up a password
  3. Disabled and stopped firewall and dnsmasq under System > Startup
  4. Enabled wireless

I have no internet access from my other devices connected over wireless. Windows says "Limited access," and iPad says "Server not found" or some such.

I proceded to bridge the lan and wan interfaces. I changed my /etc/config/network file from:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

config switch
    option name 'rtl8366rb'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '1'
    option ports '1 2 3 4 5t'

config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '0 5t'

to this:

...
config interface 'lan'
    option ifname 'eth0.1 eth0.2'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

#config interface 'wan'
#    option ifname 'eth0.2'
#    option proto 'dhcp'
...

I did this because the wiki page says "bridge the LAN VLAN together with the WAN interface" and "remove the existing WAN interface - if any." I had to telnet into failsafe mode to recover from it, so that obviously was a bad move.

I wonder if the router is configured properly but my server is not. My setup is like so:

OpenWrt <-> Ubuntu running dnsmasq, firewall, squid <-> DSL modem <-> Internet

The server has two interfaces: one of them is configured as PPPoE and the other is just a static IP. The modem is operating in transparent bridge mode. I don't think the problem is on the server but I could definitely be wrong.

Any help is appreciated.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Problem solved: I needed to set wan.proto to none. This shouldn't be necessary except that the TP-Link TL-WR1043ND v1.8 has a hardware bug that affects the WAN/LAN ports.

Thanks to g0rdon and FreezingCold on #openwrt for helping me out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.