Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

While using Debian squeeze, I was able to allow a user shutdown in xfce by adding users to the powerdev group (see here: xfce: Allow shutdown for non-root users).

Now, I upgraded my system to Debian wheezy, and some stuff in xfce doesn't seem to be running smoothly as it used to, most notably the shutdown process. Clicking on the logout icon will take me to the logout screen with "logout" enabled and "restart/shutdown" being greyed out.

This thread on the xfce forum seems to mention the same problem.

The same seems to be true for access to USB drives: Even though users are in the plugdev group, permission to the external volumes is denied (the do show up in thunar or whatever file managers are used, however).

This thread on lists.debian.org seems to mention the same problem.

The old version of xfce4 (with squeeze) was 4.6, the new version of xfce4 (with wheezy) is 4.8.

Have the config files changed? Does the newer version of xfce not care about the powerdev group any more? Any hints on troubleshooting/debugging?

share|improve this question
    
Strange indeed. I recently made a fresh Wheezy install with Xfce and faced none of these problems. This article suggests that multiarch support in Wheezy may cause some apps to break. Could this be the case in your setup? This may also be relevant to you, in case this is indeed the problem. –  Joseph R. May 18 '13 at 21:44
    
@JosephR. Just guessing, but it appears that I may now have a newer version of xfce that might try to override some system settings. For instance, after logging in at the xdm prompt, when I already had the right screen resolution settings after X had properly started up, the screen flickers while xfce is launched. This seems like xfce does some autoprobing even after X has already brought up the graphics driver and options just fine, using a modeline I put in xorg.conf ... –  zebonaut May 19 '13 at 8:13
    
Does the changelog help? I'm not sure why it isn't in its usual place in /usr/share; at least for me: I tried looking for it on my Wheezy box but couldn't find it. –  Joseph R. May 19 '13 at 9:59
add comment

1 Answer

up vote 1 down vote accepted

I had this problem too; a solution on the Debian mailing list works for me. Make these two files:

/etc/polkit-1/localauthority/50-local.d/consolekit.pkla

[restart]
Identity=unix-user:*
Action=org.freedesktop.consolekit.system.restart
ResultAny=yes

[stop]
Identity=unix-user:brian
Action=org.freedesktop.consolekit.system.stop
ResultAny=yes

/etc/polkit-1/localauthority/50-local.d/udisks.pkla

[udisks]
Identity=unix-user:*
Action=org.freedesktop.udisks*
ResultAny=yes

This part of the thread on lists.debian.org explains the underlying reasons why this is necessary.

share|improve this answer
    
Hi and Welcome to Unix & Linux! Please read the How to Answer a Question Guide. This site is a Q&A site not a forum. –  slm May 29 '13 at 22:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.