Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm a new newbie Linux Mint user but I have a lot of desire to learn. I played a little with the shutdown command typing:

sudo shutdown +20

and then:

sudo shutdown -c

I then manually hibernate my pc because I had to go out. Now I'm back and I found that I could no longer turn on the pc because once Linux is started, I can see the desktop for 1 second, and then my pc shutdown.

How can I solve this?

share|improve this question
    
When you turn the PC back on, does it boot normally or does it un-hibernate? (I have never used hibernation in Linux so am not sure exactly how you'd tell, but I assume it's pretty obvious.) Does it keep turning off on subsequent attempts? (I assume it does, but best to be sure.) –  Michael Kjörling May 15 '13 at 7:36
add comment

1 Answer 1

up vote 2 down vote accepted

you could try adding noacpi to kernel-/linux-line via grub on boot.

  1. Start PC
  2. Select First Entry in Grub
  3. Press e
  4. Append noacpi to kernel-/linux-line
  5. Press F10 if you have grub2 (for grub i don't know...maybe just press enter)

This way you should get back in your system and be able check out whats going wrong.

share|improve this answer
1  
You could also try adding single to bring up the system in single-user mode. –  Flup May 15 '13 at 7:36
1  
Note that noacpi probably won't prevent the system shutdown sequence, but it will keep the computer from powering off. It might also be a good idea to remove quiet from the kernel command line, if that parameter is present: it'll give you a lot more information about what happens during the boot process. –  Michael Kjörling May 15 '13 at 7:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.