Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I got a live CD and I tried to install it manually because it doesn't support installing.

So I booted from live cd and did:

mkfs.ext4 /dev/sda5
mount /dev/sda5 /mnt
cd /mnt
unsqaushfs /cdrom/casper/filesystem.squashfs
mv squashfs-root/* ./
rm -r squashfs-root
mount --bind /dev /mnt/dev
mount --bind /sys /mnt/sys
mount --bind /proc /mnt/proc
chroot /mnt
grub-install /dev/sda
update-grub

So I restarted and it said that it can't mount the filesystem. So I tried the same with ext2 because in the grub config stood insmod=ext2 and when I tried to boot with insmod=ext4 it said file not found. But still even with ext2 it said that it can't mount the filesystem.

share|improve this question

closed as too localized by Gilles, jasonwryan, Hauke Laging, vonbrand, slm May 13 '13 at 0:22

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What distribution/OS? –  schaiba May 12 '13 at 17:00
    
A debian based distro. –  Peter May 12 '13 at 17:03
1  
What is the exact message from grub? How is it configured? –  lgeorget May 12 '13 at 18:20
    
General error mounting filesystems. –  Peter May 12 '13 at 18:28
    
The problem was that /etc/fstab was missing so I created the file manually. After that I couldn't login because /etc/shadow was missing too so I created that file too and then everything was working. –  Peter May 12 '13 at 20:46