Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Can anyone help me out on connecting INTEX 3.5G 7.2 Mbps (aka 普创E003) Wireless USB modem in Ubuntu? Initially it is recognized as a storage device and the modprobe cmd does not create any impact on it. Here are the steps I have followed:

tech@tech-Inspiron-N5010:~$ sudo usb_modeswitch -H -v 20a6 -p f00e.

Looking for default devices ….
found matching product ID.
adding device
Found device in default mode, class or configuration (1).
Accessing device 007 on bus 002 ….
Getting the current device configuration ….
OK, got current device configuration (1).
Using first interface: 0×00.
Using endpoints 0×01 (out) and 0×81 (in).
Inquiring device details; driver will be detached ….
Looking for active driver ….
No driver found. Either detached before or never attached.

SCSI inquiry data (for identification).
Vendor String: Modem.
Model String: Disk.
Revision String: 2.31.

USB description data (for identification).
Manufacturer: Modem
Product: Modem Device.
Serial No.: 000000000002.
Sending Huawei control message ….
OK, Huawei control message sent.
-> Run lsusb to note any changes. Bye.

tech@tech-Inspiron-N5010:~$ sudo modprobe usbserial vendor=0x20a6 product=0xf00e.


T: Bus=02 Lev=02 Prnt=02 Port=01 Cnt=01 Dev#= 7 Spd=480 MxCh= 0.
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1.
P: Vendor=20a6 ProdID=f00e Rev=00.00.
S: Manufacturer=Modem
S: Product=Modem Device.
S: SerialNumber=000000000002
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=500mA.
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none).

I have tried this all. I am using the INTEX 3.5G 7.2 Mbps (aka 普创E003) Wireless USB Datacard modem and have tried to configure rules and modules also but nothing has worked.
Can anyone tell me what is the real problem?

share|improve this question
Does your modem require any special firmware? If they are proprietary, they aren't installed by default. – lgeorget May 12 '13 at 16:30
yeah it has a inbuilt driver for windows when once i start it in windows and without unplugging it restarts d pc n boot to ubuntu den it works otherwisw dnt,so vrytym i hav to b4 usin it follow dat procrdure dnt knw whether i can do it dyrctly in linux or not – user1798477 May 22 '13 at 7:16

The problem is that this modem does not switch automatically from a USB storage device to a USB Modem. Here is a simple solution.

Download This File IntexModem.

Now Extract it and execute the IntexModem program. This will configure your modem to be used with Ubuntu, Linux Mint, Debian, Crunchbangnor other Debian based OS.

You will have to run this program everytime you plug in the modem. To make things simpler, you can put it in /usr/local/bin directory and run it just by typing IntexModem in a terminal.

Note:- You may have to wait 1-2 minutes for your modem to be recognised in Network Manager.

share|improve this answer

INTEX 3.5G 7.2 Mbps (aka 普创E003) Wireless Modem Driver

Download this unofficial driver made by me with help from GunJack :


I used 20a6:f00e *usb_modeswitch* configuration obtained from my Android tablet to do the modeswitch to 20a6:1105. GunJack's method is a bit different; It involves using eject command to eject the ZeroCD virtual CDROM drive and thus force the modeswitch. My driver(till version 0.5),generic driver and IntexModem binary uses this eject based method.

Refer to this AskUbuntu thread for more details and drivers: http://askubuntu.com/questions/245256/how-to-install-and-work-with-intex-speed-3-5g-usb-datacard-in-ubuntu-lts-12

These deb packages were built and tested on Ubuntu 12.04 LTS. As these packages contain no compiled binaries,they're theoretically portable across all 32bit,64bit and other architectures and Linux distros. It's supposed to work for Debian/Ubuntu derivatives (Mint, elementaryOS, Deepin, Pinguy, Bodhi,etc). Users of other distro families (Fedora, Slackware, SUSE, Arch, Gentoo, etc.),try the generic Linux driver.

Don't confuse this with INTEX SPEED 3G Modem (aka Linktop LW273),which is an entirely different product. INTEX SPEED 3G Installer.deb won't work for INTEX 3.5G v7.2.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.