Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am new to Linux and CentOS so I may not be sure of the exact question to ask. It may be best for me to tell you what I have done. I installed a secondary 500gb HD to use for file share storage. I have partitioned, formatted, and mounted according to many different websites' instructions. I used this command to format:

mkfs.ext4 -L /Filesystem2 /dev/sdb1

This caused the new file system to be displayed in "Computer" via the GUI. However, it was inaccessible. Once I mounted it, I can access it from the CLI and the GUI, but it no longer shows up in "Computer". Using the GUI as a user, I have to search to find the mounted drive. It does not appear anywhere. I would like to have it like Windows where it appears as a secondary drive. I don't know how to do this or the Linux terminology for it.

share|improve this question
    
Several questions arise: Which GUI do you use? How and where do you mount it? Is it not always mounted at the same path? –  Hauke Laging May 8 '13 at 16:36
    
I am using GNOME. Commands one by one as root: –  Joshua May 8 '13 at 16:43
    
Better edit your question than explain this in comments. –  Hauke Laging May 8 '13 at 16:45
    
I am using GNOME. Commands one by one as root: 1) mkfs.ext4 -L /Filesystem2 /dev/sdb1 -> Visible in GNOME/Computer as user but inaccessible. 2) mkdir /Filesystem2 3) mount /dev/sdb1 /Filesystem2 -> Disappeared in GNOME/Computer as user, can find Filesystem2 via search but I have no idea where it is or how to access it without searching. I'd rather it be another Filesystem drive in Computer. Hope this helps. –  Joshua May 8 '13 at 16:49
    
You should easily find /Filesystem2 with every file manager tool. And you can create symlinks to this path wherever you prefer to see them. "It's not a bug it's a feature" – "Computer" is supposed to show only unmounted volumes. I don't know if that can be configured but should not be necessary. –  Hauke Laging May 8 '13 at 16:53

1 Answer 1

up vote 1 down vote accepted

You probably want the disk mounted automatically. You need an entry in /etc/fstab for this. You can do this with any editor (just copy another line and modify it) but there certainly is a distro tool for the job (I don't know CentOS, maybe someone else can add this information).

If you use an editor then first make a backup of the file and after the modificationtry to mount the partition from a shell (as root if necessary) with the command mount /dev/sdb1 (if /dev/sdb1 is the device identification you have used in fstab) before you reboot. Because if you have created an error in the file your system will probably not boot any more.

share|improve this answer
    
He gave the filesystem a label (hint: -L /Filesystem2). It is best to use that for setting up his fstab, since the entry in /dev/ can change based on various things. –  Tim May 8 '13 at 17:11
    
I set the disk to mount automatically. After reboot, the user account gets a black screen when attempting to log in via VNC to GNOME. I end up having to force quit the VNC client on my local Windows machine. I can log in via VNC to GNOME as root (not recommended). PuTTY works fine as any user. Could some update have causes this??? –  Joshua May 8 '13 at 21:09
    
@Joshua Volume mounting should not be related to VNC access at all. Can you login locally yet (as a user)? User login fails e.g. if your $HOME directory isn't available. But adding a volume should not affect that. What do you get as root with ls ~user? –  Hauke Laging May 8 '13 at 21:36
    
@HaukeLaging - I think the issue was when I edited the /etc/fstab to auto mount. The /dev/sdb1 has a label of /Filesystem2 and I auto mounted it to a folder named /Filesystem2. I created a new folder /drive2 and edited the /etc/fstab to mount /dev/sdb1 to it and now I have access via VNC again. –  Joshua May 8 '13 at 22:06
    
@HaukeLaging - Once /etc/fstab was edited and system rebooted, it works as you described in your answer. Now, do i use chmod to give users access to the new mounted drive? –  Joshua May 8 '13 at 22:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.