Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have ArchLinux embedded in userspace on my Samsung Series 3 Chromebook. The version of GCC I have installed via pacman is 4.7.2. I'd like a newer version, and the package database here shows that the Core repository has GCC 4.8.0-4. However, when I run sudo pacman -Syu, I am told there is nothing to do. I'm happy to be patient, though as a newcomer to ArchLinux, I wonder if someone can tell me why my version is not yet 4.8.

share|improve this question

1 Answer 1

up vote 5 down vote accepted

The ARM package has only just been updated; it likely just hasn't propagated to your mirror yet.

You can change your mirror in /etc/pacman.d/mirrorlist and then force a rsync of your local database with pacman -Syyu. Or you could just wait for the package to arrive on your current mirror.

share|improve this answer
    
I'm still with GCC 4.7.2. In my /etc/pacman.d/mirrorlist I'm setting Server to mirror.archlinuxarm.org/armv7h/core Browsing there shows only GCC 4.7.2. Other mirrors are listed below (in mirrorlist) by country, but behave similarly. –  user7543 May 29 '13 at 20:49
    
By the way, isn't it pacman -Syu? –  user7543 May 29 '13 at 20:51
1  
@user7543 -Syyu forces a resync of the local db... –  jasonwryan May 29 '13 at 20:53
    
Ah, ok, thanks. Even so, I'm still with GCC 4.7.2. –  user7543 May 29 '13 at 20:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.