Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I wanted to try a live openSUSE 12.3 (64-bit) system on my MacBook 7,1, however:

  • When I do it with a LiveUSB created with UNetbootin, it's not recognized as bootable
  • When I do it with a LiveCD created with Disk Utility, it boots, but it hangs on the screen with the black-blue background with the openSUSE chameleon on a plant on the right. No matter if I boot it in EFI-mode or not.

What is going wrong? It's not really important however, I just wanted to try it for fun.

share|improve this question
1  
what openSUSE version? –  peterph May 7 '13 at 10:35
    
@peterph 12.3. Added to my question. Sorry for forgetting to include. –  Jop May 7 '13 at 12:23
    
It can easily be broken (frankly, many releases are). Can you try regular installation? –  peterph May 7 '13 at 14:49
    
@peterph Nah, I just wanted to toy around with a live session, I'd rather not install. –  Jop May 18 '13 at 12:31
    
You can create your own iso at susestudio.com - and put in whatever you think you are going to need. –  peterph May 18 '13 at 22:15
add comment

1 Answer

I tried to install OpenSuse 12.3 on a Macbook (not Pro) with many problems with the X driver.

Finally I booted, and changed the kernel line beginning with vmlinuz to end with:

xdriver=fbdev nodomeset

and it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.