Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using RHEL 6.4 on a HP-Z620 Workstation.Whenever this machine starts up, it comes up with Graphics Mode e.g. Splash Screen,Red Hat Logo etc.

But I want my machine to start in Text Mode. e.g. I want my machine showing all Kernel Messages(saying which services are being started).

Previous versions of RHEL provided an option

Press I for interactive startup

But this version does not provide that. How to get back that feature?

share|improve this question
add comment

2 Answers

Edit /etc/grub.conf back it up first though.

Remove rhgb and quiet

Reboot.

Or just hit the down arrow key when the system boots to switch to no splash.

share|improve this answer
2  
fwiw "quiet" just causes the kernel to not print out as much information. Removal of "rhgb" is sufficient for removing he graphical boot splash. –  Joel Davis May 4 '13 at 20:45
add comment

An alternative method is to disable this through plymouth:

plymouth-set-default-plugin text
/usr/libexec/plymouth/plymouth-update-initrd

If you're interested in more about plymouth check out the references to it below. It's what powers the bootsplash for Red Hat based distros.

References

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.