Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed centos 6.4 on a desktop and wanted to access it mostly remotely. For this, I tried http://www.serverschool.com/server-configuration/3-ways-to-configure-services-to-start-at-boot-in-centos-part-1/ That didn't work - so tried Start network service at boot time on CentOS because my desktop is also on wlan. That didn't work. So now I am stuck. Any inputs appreciated on how to troubleshoot this.

share|improve this question
    
You can use ntsysv command to enable ssh service at startup –  Rahul Patil May 2 '13 at 8:55
    
Thanks the problem (perhaps) is not that sshd is not started. The problem is that wlan card is not up until I login. I am not sure on how to confirm this though. –  doon May 2 '13 at 9:23

1 Answer 1

Edit the ifcfg for this interface. For example, using wlan0.

/etc/sysconfig/network-scripts/ifcfg-wlan0

Verify that the ONBOOT selection is enabled.

ONBOOT="yes"

Configure services to run at boot

chkconfig messagebus off
chkconfig wpa_supplicant off
chkconfig NetworkManager off
chkconfig network on

Reference link

share|improve this answer
    
Thanks. I looked at the link. Now the machine hangs on booting. Here is what I did 1. Looked at /etc/sysconfig/network-scripts/ifcfg-wlan0. Could not find it.Created one file with ifcfg-wlan0 and added ONBOOT-"yes" I did do iwconfig and it reported the wireless card fine. Then I just did vi /etc/sysconfig/wpa_supplicant and added interfaces = -iwlan0. I did not go to the next step of editing wpa_supplicant.conf since I did not know what to put it in psk="NETWORKPSK". I did do all the chkconfig that were mentioned and rebooted. Now the machine hangs. Is there a way to troubleshoot this now? –  doon May 6 '13 at 14:08
    
use ONBOOT="yes" instead of ONBOOT-"yes" –  Rahul Patil May 7 '13 at 1:50
    
Sorry that was a typo in the message I did do ONBOOT="yes". So now this is what I have done. Created ifcfg-wlan with ONBOOT="yes". Then vi /etc/sysconfig/wpa_supplicant and added interfaces = -iwlan0. Then configured the wpa_supplicant.confg with correct PSK/ssid. Then did the chkconfig. Reboot. Nothing. –  doon May 10 '13 at 17:40
    
Then configured the wpa_supplicant.conf as on linuxdo.blogspot.in/2012/06/…. When I do this wpa_supplicant -iwlan0 -c/root/linuxdo.conf I get "Trying to associate with 00:8e:f2:5d:23:6c (SSID='CorrectSSID' freq=2442 MHz) CTRL-EVENT-DISCONNECTED bssid=00:8e:f2:5d:23:6c reason=0 Associated with 00:8e:f2:5d:23:6c WPA: Key negotiation completed with 00:8e:f2:5d:23:6c [PTK=CCMP GTK=CCMP] CTRL-EVENT-CONNECTED - Connection to 00:8e:f2:5d:23:6c completed (auth) [id=0 id_str=] WPA: Invalid EAPOL-Key MIC - dropping packet" . –  doon May 10 '13 at 17:41
    
So ultimately it seems that there is a problem in connecting to the wireless card via wpa_supplicant but no issue with network manager (which I presume does not use wpa_supplicant). I don't know if this can be discussed any longer in this forum but just wanted to put it out there. Thanks –  doon May 10 '13 at 18:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.