Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently upgraded to Fedora 18 with gnome. My function keys started to do things like open the cd player (F12) and turn the volume up (F11) and down (F10). I'd like to just pass those though to the app.

How do I turn off gnome's interception of the function keys and just let the presses though to applications?

The Keyboard system settings is empty in the "Custom Shortcuts" tab. I don't see any keys in "Navigation" that map to just function keys. "Sound and Media" has a bunch of mappings, but they don't mention keys, just functions and I can't seem to remove/deactivate them. "Windows" also don't have plan function keys, just modified ones like Alt+F7.

Results: Turns out I had a multimedia keyboard and didn't know it. I must have hit a hotkey accidentally and switched it. A bit of searching and hotkey discovery solved the problem! It was keyboard issue. One helpful trick was to plug in another keyboard, which didn't have the same problems. This narrowed it down to the keyboard.

share|improve this question
    
What does the keyboard dialog show? (User Menu -> System Settings -> Keyboard -> Shortcuts). –  slm May 1 '13 at 23:27
1  
What type of keyboard do you have? Is the row of F1 - F12 keys multi-function? If so perhaps the keyboard has these keys in the alternate mode? –  slm May 1 '13 at 23:31
    
That was it sim, that answer makes me feel silly. If you write it up below I'll accept it. –  Paul Rubel May 2 '13 at 14:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.